summaryrefslogtreecommitdiff
path: root/dns/ldns
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2015-02-25 14:44:41 +0000
committerMark Felder <feld@FreeBSD.org>2015-02-25 14:44:41 +0000
commit7c45c72c916cc300ed95b06b05b3c6582ca14d36 (patch)
treec49c1db9ab753f81479b4e7b3793bd45ddfefaea /dns/ldns
parentd92c3969a9f286a5f413ae4c3b105c7a2ee3a080 (diff)
downloadfreebsd-ports-7c45c72c916cc300ed95b06b05b3c6582ca14d36.zip
Fix issues with LibreSSL
PR: 191853 Approved by: maintainer
Diffstat (limited to 'dns/ldns')
-rw-r--r--dns/ldns/Makefile3
-rw-r--r--dns/ldns/files/patch-drill_Makefile.in11
-rw-r--r--dns/ldns/files/patch-examples_Makefile.in28
-rw-r--r--dns/ldns/files/patch-examples_configure.ac11
-rw-r--r--dns/ldns/files/patch-examples_ldns-signzone.c18
5 files changed, 70 insertions, 1 deletions
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index 2cf94b651e14..3b87a4e1cfaf 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ldns
PORTVERSION= 1.6.17
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= dns
MASTER_SITES= http://www.nlnetlabs.nl/downloads/ldns/ \
LOCAL/ehaupt
@@ -80,6 +80,7 @@ INSTALL_TARGET+=install-manpages
.if ${PORT_OPTIONS:MGOST}
. if ${OSVERSION} < 1000015
BUILD_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
+CONFLICTS+= libressl-*
. endif
.else
NO_GOST= --disable-gost
diff --git a/dns/ldns/files/patch-drill_Makefile.in b/dns/ldns/files/patch-drill_Makefile.in
new file mode 100644
index 000000000000..1f47900a29ee
--- /dev/null
+++ b/dns/ldns/files/patch-drill_Makefile.in
@@ -0,0 +1,11 @@
+--- drill/Makefile.in.orig 2014-01-10 21:04:41 UTC
++++ drill/Makefile.in
+@@ -98,7 +98,7 @@ doc:
+
+ install: all
+ $(INSTALL) -d $(DESTDIR)$(bindir)
+- $(INSTALL) drill $(DESTDIR)$(bindir)/drill
++ $(INSTALL) -s drill $(DESTDIR)$(bindir)/drill
+ $(INSTALL) -m 644 drill.1 $(DESTDIR)$(mandir)/man1/drill.1
+
+ uninstall:
diff --git a/dns/ldns/files/patch-examples_Makefile.in b/dns/ldns/files/patch-examples_Makefile.in
new file mode 100644
index 000000000000..15dc6e203863
--- /dev/null
+++ b/dns/ldns/files/patch-examples_Makefile.in
@@ -0,0 +1,28 @@
+--- examples/Makefile.in.orig 2014-01-10 21:04:41 UTC
++++ examples/Makefile.in
+@@ -169,7 +169,7 @@ install: $(PROGRAMS) $(SSL_PROGRAMS)
+ $(INSTALL) -d -m 755 $(DESTDIR)$(mandir)
+ $(INSTALL) -d -m 755 $(DESTDIR)$(mandir)/man1
+ for i in $(PROGRAMS) $(SSL_PROGRAMS); do \
+- $(libtool) --tag=CC --mode=install ${INSTALL} -c $$i $(DESTDIR)$(bindir) ; \
++ $(libtool) --tag=CC --mode=install ${INSTALL} -s -c $$i $(DESTDIR)$(bindir) ; \
+ if test -f $$i.1 ; \
+ then $(INSTALL) -c -m 644 $$i.1 $(DESTDIR)$(mandir)/man1/$$i.1 ; \
+ else $(INSTALL) -c -m 644 $(srcdir)/$$i.1 $(DESTDIR)$(mandir)/man1/$$i.1 ; \
+@@ -182,14 +182,14 @@ install-static: all-static
+ $(INSTALL) -d -m 755 $(DESTDIR)$(mandir)
+ $(INSTALL) -d -m 755 $(DESTDIR)$(mandir)/man1
+ for i in $(PROGRAMS); do \
+- $(libtool) --tag=CC --mode=install ${INSTALL} -c $$i.stc $(DESTDIR)$(bindir) ; \
++ $(libtool) --tag=CC --mode=install ${INSTALL} -s -c $$i.stc $(DESTDIR)$(bindir) ; \
+ if test -f $$i.1 ; \
+ then $(INSTALL) -c -m 644 $$i.1 $(DESTDIR)$(mandir)/man1/$$i.1 ; \
+ else $(INSTALL) -c -m 644 $(srcdir)/$$i.1 $(DESTDIR)$(mandir)/man1/$$i.1 ; \
+ fi ; \
+ done
+ for i in $(SSL_PROGRAMS); do \
+- $(libtool) --tag=CC --mode=install ${INSTALL} -c $$i.stc-ssl $(DESTDIR)$(bindir) ; \
++ $(libtool) --tag=CC --mode=install ${INSTALL} -s -c $$i.stc-ssl $(DESTDIR)$(bindir) ; \
+ if test -f $$i.1 ; \
+ then $(INSTALL) -c -m 644 $$i.1 $(DESTDIR)$(mandir)/man1/$$i.1 ; \
+ else $(INSTALL) -c -m 644 $(srcdir)/$$i.1 $(DESTDIR)$(mandir)/man1/$$i.1 ; \
diff --git a/dns/ldns/files/patch-examples_configure.ac b/dns/ldns/files/patch-examples_configure.ac
new file mode 100644
index 000000000000..bac79cebfc59
--- /dev/null
+++ b/dns/ldns/files/patch-examples_configure.ac
@@ -0,0 +1,11 @@
+--- examples/configure.ac.orig 2014-01-10 21:04:41 UTC
++++ examples/configure.ac
+@@ -207,6 +207,8 @@ case "$enable_dane" in
+ ;;
+ esac
+
++AC_CHECK_FUNCS(ENGINE_load_cryptodev)
++
+ LDFLAGS="$tmp_LDFLAGS"
+ LIBS="$tmp_LIBS"
+
diff --git a/dns/ldns/files/patch-examples_ldns-signzone.c b/dns/ldns/files/patch-examples_ldns-signzone.c
new file mode 100644
index 000000000000..f14a920c00ba
--- /dev/null
+++ b/dns/ldns/files/patch-examples_ldns-signzone.c
@@ -0,0 +1,18 @@
+--- examples/ldns-signzone.c.orig 2014-01-10 21:04:41 UTC
++++ examples/ldns-signzone.c
+@@ -470,6 +470,7 @@ main(int argc, char *argv[])
+ case 'A':
+ signflags |= LDNS_SIGN_DNSKEY_WITH_ZSK;
+ break;
++#ifdef HAVE_ENGINE_LOAD_CRYPTODEV
+ case 'E':
+ ENGINE_load_builtin_engines();
+ ENGINE_load_dynamic();
+@@ -494,6 +495,7 @@ main(int argc, char *argv[])
+ ENGINE_set_default(engine, 0);
+ }
+ break;
++#endif
+ case 'k':
+ eng_key_l = strchr(optarg, ',');
+ if (eng_key_l && strlen(eng_key_l) > 1) {