summaryrefslogtreecommitdiff
path: root/dns/knot-resolver
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2017-02-26 15:17:58 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2017-02-26 15:17:58 +0000
commit1e9fe3f4df5c782a8555d8cb7385f78b486d4272 (patch)
tree8977434152588af08edfdc9ca0225ccdf12febd1 /dns/knot-resolver
parent0ba69cf15033681e7b43640239f79894f03ca965 (diff)
downloadfreebsd-ports-1e9fe3f4df5c782a8555d8cb7385f78b486d4272.zip
dns/knot-resolver: update to 1.2.3
- tweak make variables - remove unneeded local patches PR: 217326 Submitted by: Leo Vandewoestijne <freebsd@dns-lab.com> (maintainer)
Diffstat (limited to 'dns/knot-resolver')
-rw-r--r--dns/knot-resolver/Makefile10
-rw-r--r--dns/knot-resolver/distinfo6
-rw-r--r--dns/knot-resolver/files/patch-daemon_daemon.mk13
-rw-r--r--dns/knot-resolver/files/patch-lib_lib.mk13
-rw-r--r--dns/knot-resolver/files/patch-lib_nsrep.h10
-rw-r--r--dns/knot-resolver/files/patch-lib_resolve.h10
-rw-r--r--dns/knot-resolver/files/patch-platform.mk10
-rw-r--r--dns/knot-resolver/files/pkg-message.in2
-rw-r--r--dns/knot-resolver/pkg-plist8
9 files changed, 13 insertions, 69 deletions
diff --git a/dns/knot-resolver/Makefile b/dns/knot-resolver/Makefile
index 5bcd676bb6db..0bd28244ffd4 100644
--- a/dns/knot-resolver/Makefile
+++ b/dns/knot-resolver/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= knot-resolver
-PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTVERSION= 1.2.3
CATEGORIES= dns ipv6
MASTER_SITES= https://secure.nic.cz/files/knot-resolver/ \
https://dns.company/downloads/knot-resolver/
@@ -22,10 +21,11 @@ LIB_DEPENDS= libknot.so:dns/knot2 \
CONFLICTS= knot-1.* knot1-[0-6].*
-MAKE_ARGS+= PREFIX=${PREFIX}
+MAKE_ARGS+= PREFIX=${LOCALBASE}
MAKE_ARGS+= LIBDIR=${PREFIX}/lib
-MAKE_ARGS+= PKG_CONFIG_PATH=${LOCALBASE}/libdata/pkgconfig
-MAKE_ARGS+= lmdb_CFLAGS=-I${LOCALBASE}/include lmdb_LIBS=-llmdb
+MAKE_ARGS+= MANDIR=${PREFIX}/man
+MAKE_ARGS+= PKGCONFIGDIR=${PREFIX}/libdata/pkgconfig
+MAKE_ARGS+= lmdb_CFLAGS=-I${PREFIX}/include lmdb_LIBS=-llmdb
USES= gmake libtool pkgconfig tar:xz
USE_CSTD= c99
diff --git a/dns/knot-resolver/distinfo b/dns/knot-resolver/distinfo
index e5d70b78011f..bbd4f0fb46c8 100644
--- a/dns/knot-resolver/distinfo
+++ b/dns/knot-resolver/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1472151881
-SHA256 (knot-resolver-1.1.1.tar.xz) = f848f6dd2c7a2c1a5067d3bd95dacb752d1f3d8dc9d5ccc0c34a4540d00ab54a
-SIZE (knot-resolver-1.1.1.tar.xz) = 661612
+TIMESTAMP = 1487892509
+SHA256 (knot-resolver-1.2.3.tar.xz) = 81a773f182112b4e11935223f900cfbcca8624f2c382b1e39a68d7c3db81c921
+SIZE (knot-resolver-1.2.3.tar.xz) = 1045548
diff --git a/dns/knot-resolver/files/patch-daemon_daemon.mk b/dns/knot-resolver/files/patch-daemon_daemon.mk
deleted file mode 100644
index dfca130d8376..000000000000
--- a/dns/knot-resolver/files/patch-daemon_daemon.mk
+++ /dev/null
@@ -1,13 +0,0 @@
---- daemon/daemon.mk.orig 2016-08-24 12:05:47 UTC
-+++ daemon/daemon.mk
-@@ -46,8 +46,8 @@ daemon: $(kresd)
- daemon-install: kresd-install bindings-install
- ifneq ($(SED),)
- $(SED) -e "s/@VERSION@/$(MAJOR).$(MINOR).$(PATCH)/" -e "s/@DATE@/$(date)/" doc/kresd.8.in > doc/kresd.8
-- $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/share/man/man8/
-- $(INSTALL) -m 0644 doc/kresd.8 $(DESTDIR)$(PREFIX)/share/man/man8/
-+ $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/man/man8/
-+ $(INSTALL) -m 0644 doc/kresd.8 $(DESTDIR)$(PREFIX)/man/man8/
- endif
- daemon-clean: kresd-clean
- @$(RM) daemon/lua/*.inc
diff --git a/dns/knot-resolver/files/patch-lib_lib.mk b/dns/knot-resolver/files/patch-lib_lib.mk
deleted file mode 100644
index 2f8479f63b5f..000000000000
--- a/dns/knot-resolver/files/patch-lib_lib.mk
+++ /dev/null
@@ -1,13 +0,0 @@
---- lib/lib.mk.orig 2016-08-24 12:05:47 UTC
-+++ lib/lib.mk
-@@ -83,8 +83,8 @@ libkres.pc:
- @echo 'Libs: -L$${libdir} -lkres' >> $@
- @echo 'Cflags: -I$${includedir}' >> $@
- libkres-pcinstall: libkres.pc libkres-install
-- $(INSTALL) -d -m 755 $(DESTDIR)$(LIBDIR)/pkgconfig/
-- $(INSTALL) -m 644 $< $(DESTDIR)$(LIBDIR)/pkgconfig/
-+ $(INSTALL) -d -m 755 $(DESTDIR)$(PKG_CONFIG_PATH)/
-+ $(INSTALL) -m 644 $< $(DESTDIR)$(PKG_CONFIG_PATH)/
-
- # Targets
- lib: $(libkres)
diff --git a/dns/knot-resolver/files/patch-lib_nsrep.h b/dns/knot-resolver/files/patch-lib_nsrep.h
deleted file mode 100644
index 09501548f117..000000000000
--- a/dns/knot-resolver/files/patch-lib_nsrep.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/nsrep.h.orig 2016-08-24 12:05:47 UTC
-+++ lib/nsrep.h
-@@ -19,6 +19,7 @@
- #include <netinet/in.h>
- #include <libknot/dname.h>
- #include <limits.h>
-+#include <sys/socket.h>
-
- #include "lib/defines.h"
- #include "lib/generic/map.h"
diff --git a/dns/knot-resolver/files/patch-lib_resolve.h b/dns/knot-resolver/files/patch-lib_resolve.h
deleted file mode 100644
index 4393fef6e0ef..000000000000
--- a/dns/knot-resolver/files/patch-lib_resolve.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/resolve.h.orig 2016-08-24 12:05:47 UTC
-+++ lib/resolve.h
-@@ -18,6 +18,7 @@
-
- #include <netinet/in.h>
- #include <libknot/packet/pkt.h>
-+#include <sys/socket.h>
-
- #include "lib/cookies/control.h"
- #include "lib/cookies/lru_cache.h"
diff --git a/dns/knot-resolver/files/patch-platform.mk b/dns/knot-resolver/files/patch-platform.mk
deleted file mode 100644
index 49c6a84d3f44..000000000000
--- a/dns/knot-resolver/files/patch-platform.mk
+++ /dev/null
@@ -1,10 +0,0 @@
---- platform.mk.orig 2016-08-24 12:05:47 UTC
-+++ platform.mk
-@@ -49,7 +49,6 @@ else
- BINFLAGS += -pie
- LDFLAGS += -Wl,-z,relro,-z,now
- endif
-- LDFLAGS += -ldl
- endif
- endif
-
diff --git a/dns/knot-resolver/files/pkg-message.in b/dns/knot-resolver/files/pkg-message.in
index d86f07afcf8c..644ccbedae9a 100644
--- a/dns/knot-resolver/files/pkg-message.in
+++ b/dns/knot-resolver/files/pkg-message.in
@@ -6,5 +6,5 @@
To run as daemon see:
- http://knot-resolver.readthedocs.io/en/latest/daemon.html
-
+
######################################################################
diff --git a/dns/knot-resolver/pkg-plist b/dns/knot-resolver/pkg-plist
index fbdbbbe94693..aad9ca5bc08f 100644
--- a/dns/knot-resolver/pkg-plist
+++ b/dns/knot-resolver/pkg-plist
@@ -13,6 +13,7 @@ include/libkres/control.h
include/libkres/dnssec.h
include/libkres/helper.h
include/libkres/layer.h
+include/libkres/lru.h
include/libkres/lru_cache.h
include/libkres/map.h
include/libkres/module.h
@@ -46,8 +47,6 @@ lib/kdns_modules/http/epoch.css
lib/kdns_modules/http/epoch.js
lib/kdns_modules/http/favicon.ico
lib/kdns_modules/http/glyphicons-halflings-regular.woff2
-lib/kdns_modules/http/h2_connection.lua
-lib/kdns_modules/http/h2_stream.lua
lib/kdns_modules/http/jquery.js
lib/kdns_modules/http/kresd.css
lib/kdns_modules/http/kresd.js
@@ -55,20 +54,21 @@ lib/kdns_modules/http/main.tpl
lib/kdns_modules/http/selectize.bootstrap3.min.css
lib/kdns_modules/http/selectize.min.css
lib/kdns_modules/http/selectize.min.js
-lib/kdns_modules/http/server.lua
lib/kdns_modules/http/topojson.js
lib/kdns_modules/ketcd.lua
lib/kdns_modules/kres.lua
+lib/kdns_modules/kres-gen.lua
lib/kdns_modules/policy.lua
lib/kdns_modules/predict.lua
lib/kdns_modules/prometheus.lua
lib/kdns_modules/renumber.lua
lib/kdns_modules/stats.so
lib/kdns_modules/trust_anchors.lua
+lib/kdns_modules/version.lua
lib/kdns_modules/view.lua
lib/kdns_modules/zonefile.lua
lib/libkres.so
-lib/libkres.so.1
+lib/libkres.so.2
libdata/pkgconfig/libkres.pc
man/man8/kresd.8.gz
sbin/kresd