summaryrefslogtreecommitdiff
path: root/dns/flamethrower
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-02-05 18:24:07 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-02-05 18:24:07 +0000
commit4179c5b405a65e87b35fa498e47a14fa050bc092 (patch)
treea4402a5f68a2c51327ae1a8ee9fcce5eb18cb2c8 /dns/flamethrower
parent3662bd821ecce902890a00e2d70a26d1886d61b2 (diff)
downloadfreebsd-ports-4179c5b405a65e87b35fa498e47a14fa050bc092.zip
New port: dns/flamethrower
Flamethrower is a small, fast, configurable tool for functional testing, benchmarking, and stress testing DNS servers and networks. It supports IPv4, IPv6, UDP and TCP, and has a modular system for generating queries used in the tests. It was built as an alternative to dnsperf, and many of the command line options are compatible. WWW: https://github.com/DNS-OARC/flamethrower PR: 235521 Submitted by: Leo Vandewoestijne <freebsd@dns.company>
Diffstat (limited to 'dns/flamethrower')
-rw-r--r--dns/flamethrower/Makefile31
-rw-r--r--dns/flamethrower/distinfo3
-rw-r--r--dns/flamethrower/pkg-descr9
3 files changed, 43 insertions, 0 deletions
diff --git a/dns/flamethrower/Makefile b/dns/flamethrower/Makefile
new file mode 100644
index 000000000000..8b41699a39f0
--- /dev/null
+++ b/dns/flamethrower/Makefile
@@ -0,0 +1,31 @@
+# Created by: Leo Vandewoestijne <freebsd@dns.company>
+# $FreeBSD$
+
+PORTNAME= flamethrower
+PORTVERSION= 0.9
+CATEGORIES= dns
+
+MAINTAINER= freebsd@dns.company
+COMMENT= DNS performance and functional testing utility
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libuv.so:devel/libuv \
+ libldns.so:dns/ldns
+
+USES= cmake compiler:c++17-lang pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= DNS-OARC
+GH_TAGNAME= 73b9815
+
+INSTALL_TARGET=
+TEST_TARGET= ${BUILD_WRKSRC}/tests
+
+PLIST_FILES= bin/flame
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/flame ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/dns/flamethrower/distinfo b/dns/flamethrower/distinfo
new file mode 100644
index 000000000000..af92a23a01d7
--- /dev/null
+++ b/dns/flamethrower/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549292397
+SHA256 (DNS-OARC-flamethrower-0.9-73b9815_GH0.tar.gz) = 7c8ab9c1f1af60744564db4b524abc1708b848e1454d8fa10ca3b1aa8e1f0c23
+SIZE (DNS-OARC-flamethrower-0.9-73b9815_GH0.tar.gz) = 272544
diff --git a/dns/flamethrower/pkg-descr b/dns/flamethrower/pkg-descr
new file mode 100644
index 000000000000..4014107cec94
--- /dev/null
+++ b/dns/flamethrower/pkg-descr
@@ -0,0 +1,9 @@
+Flamethrower is a small, fast, configurable tool for functional
+testing, benchmarking, and stress testing DNS servers and networks.
+It supports IPv4, IPv6, UDP and TCP, and has a modular system for
+generating queries used in the tests.
+
+It was built as an alternative to dnsperf, and many of the command
+line options are compatible.
+
+WWW: https://github.com/DNS-OARC/flamethrower