summaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-10 21:28:00 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-10 21:28:00 +0000
commitf53e8ac369709fa010165159e4b2d254a918f572 (patch)
tree51996307c12038108aed5662408a3e6fb6b50499 /devel
parent050aeba4457a30b2de7835ef4b0c119389fc36df (diff)
downloadfreebsd-ports-f53e8ac369709fa010165159e4b2d254a918f572.zip
Add py-vistir 0.5.2
vistir is a library full of utility functions designed to make life easier. vistir provides several categories of functionality, including: - Backports - Compatibility Shims - Context Managers - Miscellaneous Utilities - Path Utilities WWW: https://github.com/sarugaku/vistir
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-vistir/Makefile32
-rw-r--r--devel/py-vistir/distinfo3
-rw-r--r--devel/py-vistir/pkg-descr10
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b6d2523d9fd8..068bfb30282f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5175,6 +5175,7 @@
SUBDIR += py-virtualenv-clone
SUBDIR += py-virtualenvwrapper
SUBDIR += py-visitor
+ SUBDIR += py-vistir
SUBDIR += py-voluptuous
SUBDIR += py-vsts
SUBDIR += py-vsts-cd-manager
diff --git a/devel/py-vistir/Makefile b/devel/py-vistir/Makefile
new file mode 100644
index 000000000000..da27e3b5fc45
--- /dev/null
+++ b/devel/py-vistir/Makefile
@@ -0,0 +1,32 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= vistir
+PORTVERSION= 0.5.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Miscellaneous utilities for filesystems, paths, projects, subprocesses and more
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>=0:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= REQUESTS SPINNER
+REQUESTS_DESC= Requests session support
+SPINNER_DESC= Terminal spinner support
+
+REQUESTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
+SPINNER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaspin>=0:devel/py-yaspin@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/devel/py-vistir/distinfo b/devel/py-vistir/distinfo
new file mode 100644
index 000000000000..a0d6736d0636
--- /dev/null
+++ b/devel/py-vistir/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1607539619
+SHA256 (vistir-0.5.2.tar.gz) = eff1d19ef50c703a329ed294e5ec0b0fbb35b96c1b3ee6dcdb266dddbe1e935a
+SIZE (vistir-0.5.2.tar.gz) = 76680
diff --git a/devel/py-vistir/pkg-descr b/devel/py-vistir/pkg-descr
new file mode 100644
index 000000000000..97759c9bf088
--- /dev/null
+++ b/devel/py-vistir/pkg-descr
@@ -0,0 +1,10 @@
+vistir is a library full of utility functions designed to make life easier.
+
+vistir provides several categories of functionality, including:
+- Backports
+- Compatibility Shims
+- Context Managers
+- Miscellaneous Utilities
+- Path Utilities
+
+WWW: https://github.com/sarugaku/vistir