summaryrefslogtreecommitdiff
path: root/devel/qca/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /devel/qca/Makefile
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadfreebsd-ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'devel/qca/Makefile')
-rw-r--r--devel/qca/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/qca/Makefile b/devel/qca/Makefile
index d3b395f57b2b..caea5ce6d33d 100644
--- a/devel/qca/Makefile
+++ b/devel/qca/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
-USES= cmake:outsource tar:xz
+USES= cmake tar:xz
CMAKE_ARGS= -DBUILD_PLUGINS=none -DBUILD_TESTS=no \
-DPKGCONFIG_INSTALL_PREFIX=${PREFIX}/libdata/pkgconfig \
-DQCA_FEATURE_INSTALL_DIR=${QT_MKSPECDIR}/features \