summaryrefslogtreecommitdiff
path: root/deskutils/qownnotes/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-08-06 10:15:52 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-08-06 10:15:53 +0000
commit79a76430470c67cb3b22e301e556421ae0392dc9 (patch)
treeb21a42aa07db73ec9a54c5fb278e1c8b4f0a8dbd /deskutils/qownnotes/Makefile
parent53fddf4d5ab8601f746a720252d7b8d97ebb220f (diff)
downloadfreebsd-ports-79a76430470c67cb3b22e301e556421ae0392dc9.zip
deskutils/qownnotes: the port had been updated and improved (+)
- Update QOwnNotes to the latest version 21.8.0 - Actualize Qt dependencies, most importantly, remove dreaded `webkit' - Do not build against outdated bundled Botan library and use the one from the ports instead - While here, massage the COMMENT line and port description slightly PR: 250173
Diffstat (limited to 'deskutils/qownnotes/Makefile')
-rw-r--r--deskutils/qownnotes/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/deskutils/qownnotes/Makefile b/deskutils/qownnotes/Makefile
index 416a84da2e71..2073934915be 100644
--- a/deskutils/qownnotes/Makefile
+++ b/deskutils/qownnotes/Makefile
@@ -1,18 +1,23 @@
PORTNAME= qownnotes
-DISTVERSION= 19.2.0
-PORTREVISION= 2
+PORTVERSION= 21.8.0
CATEGORIES= deskutils
MASTER_SITES= https://download.tuxfamily.org/qownnotes/src/
MAINTAINER= stobbsm@gmail.com
-COMMENT= Manage notes using nextcloud and markdown
+COMMENT= Markdown note taking program with cloud integration
LICENSE= GPLv2
+LIB_DEPENDS= libbotan-2.so:security/botan2
RUN_DEPENDS= git:devel/git
-USES= gl gmake qmake qt:5 tar:xz
+USES= gl gmake pkgconfig qmake qt:5 tar:xz xorg
USE_GL= gl
-USE_QT= buildtools_build linguisttools_build core dbus declarative gui printsupport network sql svg webkit websockets widgets xml xmlpatterns
+USE_QT= buildtools_build linguisttools_build \
+ concurrent core declarative gui network printsupport \
+ sql svg websockets widgets x11extras xml xmlpatterns
+USE_XORG= x11
+
+QMAKE_ARGS= USE_SYSTEM_BOTAN=1
.include <bsd.port.mk>