summaryrefslogtreecommitdiff
path: root/deskutils/owncloudclient
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-05-25 08:20:24 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-05-25 08:20:24 +0000
commit6a51b1787da5641be89f56e00ca250fdaa375b85 (patch)
tree2525d95fc3e716fbe2b6ded08ea8df91f6216436 /deskutils/owncloudclient
parent8c96f0636eade4e520f3703d0cebd925d36e77e4 (diff)
downloadfreebsd-ports-6a51b1787da5641be89f56e00ca250fdaa375b85.zip
Update to 2.2.0
PR: 209679 Submitted by: me Approved by: Yonas Yanfa <yonas at fizk.net> (maintainer)
Diffstat (limited to 'deskutils/owncloudclient')
-rw-r--r--deskutils/owncloudclient/Makefile2
-rw-r--r--deskutils/owncloudclient/distinfo5
-rw-r--r--deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp6
-rw-r--r--deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp12
-rw-r--r--deskutils/owncloudclient/files/patch-src_gui_owncloudgui.cpp8
-rw-r--r--deskutils/owncloudclient/files/patch-src_libsync_configfile.cpp4
-rw-r--r--deskutils/owncloudclient/pkg-plist6
7 files changed, 25 insertions, 18 deletions
diff --git a/deskutils/owncloudclient/Makefile b/deskutils/owncloudclient/Makefile
index c841b1f020e8..6f249146f004 100644
--- a/deskutils/owncloudclient/Makefile
+++ b/deskutils/owncloudclient/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= owncloudclient
-PORTVERSION= 2.1.1
+PORTVERSION= 2.2.0
DISTVERSIONPREFIX= v
CATEGORIES= deskutils
diff --git a/deskutils/owncloudclient/distinfo b/deskutils/owncloudclient/distinfo
index de8f0480c5ba..aead4f2ba8e6 100644
--- a/deskutils/owncloudclient/distinfo
+++ b/deskutils/owncloudclient/distinfo
@@ -1,2 +1,3 @@
-SHA256 (owncloud-client-v2.1.1_GH0.tar.gz) = 3eb349e0b5195dd48cfac3288fd45ae545266202b3e3403bc00ffaa4537a3f9d
-SIZE (owncloud-client-v2.1.1_GH0.tar.gz) = 13873040
+TIMESTAMP = 1463740754
+SHA256 (owncloud-client-v2.2.0_GH0.tar.gz) = e3e86eec8f8a07019f510359f65cfb852e380abaadb6a5505b529c1db5ed7323
+SIZE (owncloud-client-v2.2.0_GH0.tar.gz) = 14007830
diff --git a/deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp b/deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp
index 94fae0c3faea..a279b76059e6 100644
--- a/deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp
+++ b/deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp
@@ -1,8 +1,8 @@
---- src/gui/accountsettings.cpp.orig 2015-03-16 14:28:58 UTC
+--- src/gui/accountsettings.cpp.orig 2016-05-12 07:59:12 UTC
+++ src/gui/accountsettings.cpp
-@@ -30,7 +30,8 @@
- #include "selectivesyncdialog.h"
+@@ -31,7 +31,8 @@
#include "creds/abstractcredentials.h"
+ #include "tooltipupdater.h"
-#include <math.h>
+#include <climits>
diff --git a/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp b/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
index 413d71f68946..f3fc7d46d546 100644
--- a/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
+++ b/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
@@ -1,14 +1,14 @@
---- src/gui/generalsettings.cpp.orig 2015-09-01 13:50:21 UTC
+--- src/gui/generalsettings.cpp.orig 2016-05-12 07:59:12 UTC
+++ src/gui/generalsettings.cpp
-@@ -105,6 +105,7 @@ void GeneralSettings::loadMiscSettings()
+@@ -109,6 +109,7 @@ void GeneralSettings::loadMiscSettings()
void GeneralSettings::slotUpdateInfo()
{
+#if 0
- if (OCUpdater *updater = dynamic_cast<OCUpdater*>(Updater::instance())) {
- connect(updater, SIGNAL(downloadStateChanged()), SLOT(slotUpdateInfo()), Qt::UniqueConnection);
- connect(_ui->restartButton, SIGNAL(clicked()), updater, SLOT(slotStartInstaller()), Qt::UniqueConnection);
-@@ -112,9 +113,12 @@ void GeneralSettings::slotUpdateInfo()
+ OCUpdater *updater = dynamic_cast<OCUpdater*>(Updater::instance());
+ if (ConfigFile().skipUpdateCheck()) {
+ updater = 0; // don't show update info if updates are disabled
+@@ -121,9 +122,12 @@ void GeneralSettings::slotUpdateInfo()
_ui->updateStateLabel->setText(updater->statusString());
_ui->restartButton->setVisible(updater->downloadState() == OCUpdater::DownloadComplete);
} else {
diff --git a/deskutils/owncloudclient/files/patch-src_gui_owncloudgui.cpp b/deskutils/owncloudclient/files/patch-src_gui_owncloudgui.cpp
index 09019a86b3f3..5c177ddf55d8 100644
--- a/deskutils/owncloudclient/files/patch-src_gui_owncloudgui.cpp
+++ b/deskutils/owncloudclient/files/patch-src_gui_owncloudgui.cpp
@@ -1,11 +1,11 @@
---- src/gui/owncloudgui.cpp.orig 2015-03-16 14:28:58 UTC
+--- src/gui/owncloudgui.cpp.orig 2016-05-12 07:59:12 UTC
+++ src/gui/owncloudgui.cpp
-@@ -33,6 +33,8 @@
- #include "openfilemanager.h"
+@@ -34,6 +34,8 @@
+ #include "accountmanager.h"
#include "creds/abstractcredentials.h"
+#include <climits>
+
#include <QDesktopServices>
+ #include <QDir>
#include <QMessageBox>
- #include <QSignalMapper>
diff --git a/deskutils/owncloudclient/files/patch-src_libsync_configfile.cpp b/deskutils/owncloudclient/files/patch-src_libsync_configfile.cpp
index 574696b405e0..ff8edf05c12d 100644
--- a/deskutils/owncloudclient/files/patch-src_libsync_configfile.cpp
+++ b/deskutils/owncloudclient/files/patch-src_libsync_configfile.cpp
@@ -1,6 +1,6 @@
---- src/libsync/configfile.cpp.orig 2015-03-16 14:28:58 UTC
+--- src/libsync/configfile.cpp.orig 2016-05-12 07:59:12 UTC
+++ src/libsync/configfile.cpp
-@@ -383,11 +383,22 @@ bool ConfigFile::skipUpdateCheck( const
+@@ -415,11 +415,22 @@ bool ConfigFile::skipUpdateCheck( const
QString con( connection );
if( connection.isEmpty() ) con = defaultConnection();
diff --git a/deskutils/owncloudclient/pkg-plist b/deskutils/owncloudclient/pkg-plist
index 4d6e6b53425b..926f959a7958 100644
--- a/deskutils/owncloudclient/pkg-plist
+++ b/deskutils/owncloudclient/pkg-plist
@@ -28,6 +28,7 @@ share/applications/owncloud.desktop
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client-7.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client-8.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client-9.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client12.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client6.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/folderwizard_local.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/folderwizard_remote.png
@@ -58,6 +59,7 @@ share/applications/owncloud.desktop
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/index.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/installing.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/introduction.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/lowdiskspace.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/navigating.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/options.txt
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/owncloud.1.txt
@@ -71,6 +73,7 @@ share/applications/owncloud.desktop
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/comment-bright.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/comment-close.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/comment.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/default.css
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/doctools.js
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/down-pressed.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/down.png
@@ -98,6 +101,7 @@ share/applications/owncloud.desktop
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/installing.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/lowdiskspace.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/navigating.html
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/objects.inv
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/options.html
@@ -116,6 +120,7 @@ share/applications/owncloud.desktop
%%PORTDOCS%%%%DOCSDIR%%/latex/client-7.png
%%PORTDOCS%%%%DOCSDIR%%/latex/client-8.png
%%PORTDOCS%%%%DOCSDIR%%/latex/client-9.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/client12.png
%%PORTDOCS%%%%DOCSDIR%%/latex/client6.png
%%PORTDOCS%%%%DOCSDIR%%/latex/fncychap.sty
%%PORTDOCS%%%%DOCSDIR%%/latex/icon-error.png
@@ -129,6 +134,7 @@ share/applications/owncloud.desktop
%%PORTDOCS%%%%DOCSDIR%%/latex/logo-blue.pdf
%%PORTDOCS%%%%DOCSDIR%%/latex/mac-share.png
%%PORTDOCS%%%%DOCSDIR%%/latex/menu.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/newfloat.sty
%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.aux
%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.idx
%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.ilg