summaryrefslogtreecommitdiff
path: root/deskutils/egroupware/Makefile
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-06-05 11:44:37 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-06-05 11:44:37 +0000
commit51f6c32ae5fee9eab4714ad1da9c9f3f69fab34a (patch)
tree9f2c07eaac0f9a96def008c6b201d89906551126 /deskutils/egroupware/Makefile
parent71276188878b6e41645322626644bf00b5d505d0 (diff)
downloadfreebsd-ports-51f6c32ae5fee9eab4714ad1da9c9f3f69fab34a.zip
- Update to 1.8.004.20130531
- Pass maintainership to submitter - Added option descriptions PR: ports/179040 Submitted by: Danilo Egea Gondolfo <danilogondolfo@gmail.com>
Diffstat (limited to 'deskutils/egroupware/Makefile')
-rw-r--r--deskutils/egroupware/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/deskutils/egroupware/Makefile b/deskutils/egroupware/Makefile
index 4c5d7848d606..7bcd53324859 100644
--- a/deskutils/egroupware/Makefile
+++ b/deskutils/egroupware/Makefile
@@ -2,13 +2,13 @@
# $FreeBSD$
PORTNAME= eGroupware
-PORTVERSION= 1.8.004.20121024
+PORTVERSION= 1.8.004.20130531
CATEGORIES= deskutils
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}-1.8/${PORTNAME}-${PORTVERSION}
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.bz2 \
${PORTNAME}-egw-pear-${PORTVERSION}.tar.bz2
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danilogondolfo@gmail.com
COMMENT= A web based GroupWare system
BUILD_DEPENDS= ${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL \
@@ -28,11 +28,15 @@ SUB_FILES= pkg-message
SUB_LIST= EG_DIR=${EG_DIR} \
EG_DATA=${EG_DATA}
-OPTIONS_DEFINE= MYSQL POSTGRE OSSL TNEF ZIP IMAP GD LDAP MBSTRING
+OPTIONS_DEFINE= MYSQL POSTGRES OSSL TNEF ZIP IMAP GD LDAP MBSTRING
OPTIONS_DEFAULT=MYSQL OSSL TNEF ZIP IMAP
OSSL_DESC= enable SSL connection support
TNEF_DESC= decoding winmail.dat attachments in felamimail support
+IMAP_DESC= IMAP support
+MBSTRING_DESC= Support multi-byte character sets
+POSTGRES_DESC= PostgreSQL database support
+ZIP_DESC= Install PHP zip extension
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
@@ -40,7 +44,7 @@ USE_PHP+= mysql
USE_PHP+= pdo_mysql
.endif
-.if ${PORT_OPTIONS:MPOSTGRE}
+.if ${PORT_OPTIONS:MPOSTGRES}
USE_PHP+= pgsql
USE_PHP+= pdo_pgsql
.endif