summaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2021-07-31 14:49:21 +0800
committerWen Heping <wen@FreeBSD.org>2021-07-31 14:49:21 +0800
commit4bddb1cdcd360192739758d040bfffd320b93e23 (patch)
tree2db878a4e6b35b5d7fc2e13e2e2742f1e843d68f /databases
parentcf5adca736e1d6c7d74002fadbcf44ff90113e2a (diff)
downloadfreebsd-ports-4bddb1cdcd360192739758d040bfffd320b93e23.zip
databases/neo4j: Update to 3.5.28
- Fix run error of cypher-shell PR: 255103 Reported by: wen@ Approved by: maintainer(timeout, > 3 months)
Diffstat (limited to 'databases')
-rw-r--r--databases/neo4j/Makefile6
-rw-r--r--databases/neo4j/distinfo6
-rw-r--r--databases/neo4j/files/patch-bin_cypher-shell24
-rw-r--r--databases/neo4j/files/patch-bin_neo4j26
-rw-r--r--databases/neo4j/files/patch-bin_neo4j-shell37
-rw-r--r--databases/neo4j/pkg-plist132
6 files changed, 111 insertions, 120 deletions
diff --git a/databases/neo4j/Makefile b/databases/neo4j/Makefile
index c899b820dc31..bead940d5f76 100644
--- a/databases/neo4j/Makefile
+++ b/databases/neo4j/Makefile
@@ -1,5 +1,5 @@
PORTNAME= neo4j
-DISTVERSION= 3.3.2
+DISTVERSION= 3.5.28
CATEGORIES= databases java
MASTER_SITES= http://dist.neo4j.org/
DISTNAME= ${PORTNAME}-community-${DISTVERSION}-unix
@@ -14,7 +14,7 @@ RUN_DEPENDS= bash:shells/bash
WRKSRC= ${WRKDIR}/${DISTNAME:S,-unix,,}
NO_BUILD= yes
USES= shebangfix
-SHEBANG_FILES= bin/cypher-shell bin/neo4j-admin bin/neo4j-shell bin/neo4j-import
+SHEBANG_FILES= bin/cypher-shell bin/neo4j-admin bin/neo4j-import
USE_JAVA= yes
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= ${PORTNAME}.sh
@@ -36,7 +36,7 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}/libexec/tools
${INSTALL_SCRIPT} ${WRKSRC}/bin/tools/* \
${STAGEDIR}${PREFIX}/${PORTNAME}/libexec/tools
-.for name in cypher-shell neo4j neo4j-admin neo4j-import neo4j-shell
+.for name in cypher-shell neo4j neo4j-admin neo4j-import
${INSTALL_SCRIPT} ${WRKSRC}/bin/${name} ${STAGEDIR}${PREFIX}/bin
.endfor
${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}/lib/plugins
diff --git a/databases/neo4j/distinfo b/databases/neo4j/distinfo
index 599fc979d056..dae11a8d7a9b 100644
--- a/databases/neo4j/distinfo
+++ b/databases/neo4j/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518030659
-SHA256 (neo4j-community-3.3.2-unix.tar.gz) = 8a2a74f1270944d9b72f2af2c15cb350718e697af6e3800e67cb32a5d1605f6e
-SIZE (neo4j-community-3.3.2-unix.tar.gz) = 90614580
+TIMESTAMP = 1627694914
+SHA256 (neo4j-community-3.5.28-unix.tar.gz) = d08415b80d4d6956ccd6063668b6d14d31905c41a712da1522b73079e7dc0aa1
+SIZE (neo4j-community-3.5.28-unix.tar.gz) = 138229560
diff --git a/databases/neo4j/files/patch-bin_cypher-shell b/databases/neo4j/files/patch-bin_cypher-shell
index 5bddc5b4d441..f68f5191ac8c 100644
--- a/databases/neo4j/files/patch-bin_cypher-shell
+++ b/databases/neo4j/files/patch-bin_cypher-shell
@@ -1,34 +1,30 @@
---- bin/cypher-shell.orig 2018-02-07 19:48:06 UTC
+--- bin/cypher-shell.orig 2021-04-13 07:34:22 UTC
+++ bin/cypher-shell
-@@ -41,7 +41,9 @@ _find_java_cmd() {
+@@ -42,6 +42,8 @@ _find_java_cmd() {
detect_os() {
if uname -s | grep -q Darwin; then
DIST_OS="macosx"
-- elif [[ -e /etc/gentoo-release ]]; then
+ elif uname -s | grep -q FreeBSD; then
+ DIST_OS="freebsd"
-+ elif [[ -e /etc/gentoo-release ]]; then
+ elif [[ -e /etc/gentoo-release ]]; then
DIST_OS="gentoo"
else
- DIST_OS="other"
-@@ -52,7 +54,10 @@ _find_java_home() {
+@@ -53,6 +55,9 @@ _find_java_home() {
[[ "${JAVA_HOME:-}" ]] && return
-
+
case "${DIST_OS}" in
-- "macosx")
+ "freebsd")
+ JAVA_HOME="%%JAVA_HOME%%"
+ ;;
-+ "macosx")
+ "macosx")
JAVA_HOME="$(/usr/libexec/java_home -v 1.8)"
;;
- "gentoo")
-@@ -72,7 +77,7 @@ build_classpath() {
-
+@@ -73,7 +78,7 @@ build_classpath() {
+
# Then try installation directory (prefix/bin and prefix/share/cypher-shell/lib)
if [[ -z "${JARPATH}" ]]; then
- APP_HOME="${APP_HOME}/../share/cypher-shell"
-+ APP_HOME="${APP_HOME}/../neo4j/lib"
- JARPATH="$(find "${APP_HOME}" -name "cypher-shell-all.jar" )"
++ APP_HOME="${APP_HOME}/../neo4j"
+ JARPATH="$(find "${APP_HOME}" -name "cypher-shell.jar" )"
fi
}
diff --git a/databases/neo4j/files/patch-bin_neo4j b/databases/neo4j/files/patch-bin_neo4j
index c69199748b12..dff9a32b726b 100644
--- a/databases/neo4j/files/patch-bin_neo4j
+++ b/databases/neo4j/files/patch-bin_neo4j
@@ -1,36 +1,32 @@
---- bin/neo4j.orig 2018-02-07 19:48:06 UTC
+--- bin/neo4j.orig 2021-04-13 07:41:35 UTC
+++ bin/neo4j
@@ -1,4 +1,4 @@
-#!/usr/bin/env bash
+#!/usr/local/bin/bash
- # Copyright (c) 2002-2018 "Neo Technology,"
- # Network Engine for Objects in Lund AB [http://neotechnology.com]
+ # Copyright (c) "Neo4j"
+ # Neo4j Sweden AB [http://neo4j.com]
#
-@@ -63,7 +63,9 @@ build_classpath() {
+@@ -74,6 +74,8 @@ build_classpath() {
detect_os() {
if uname -s | grep -q Darwin; then
DIST_OS="macosx"
-- elif [[ -e /etc/gentoo-release ]]; then
+ elif uname -s | grep -q FreeBSD; then
+ DIST_OS="freebsd"
-+ elif [[ -e /etc/gentoo-release ]]; then
+ elif [[ -e /etc/gentoo-release ]]; then
DIST_OS="gentoo"
else
- DIST_OS="other"
-@@ -146,7 +148,10 @@ _find_java_home() {
+@@ -203,6 +205,9 @@ _find_java_home() {
[[ "${JAVA_HOME:-}" ]] && return
-
+
case "${DIST_OS}" in
-- "macosx")
+ "freebsd")
+ JAVA_HOME="%%JAVA_HOME%%"
+ ;;
-+ "macosx")
+ "macosx")
JAVA_HOME="$(/usr/libexec/java_home -v 1.8)"
;;
- "gentoo")
-@@ -162,9 +167,9 @@ _show_java_help() {
-
+@@ -219,9 +224,9 @@ _show_java_help() {
+
_setup_calculated_paths() {
if [[ -z "${NEO4J_HOME:-}" ]]; then
- NEO4J_HOME="$(cd "$(dirname "$0")"/.. && pwd)"
@@ -40,4 +36,4 @@
+ : "${NEO4J_CONF:="${NEO4J_HOME}/../etc"}"
readonly NEO4J_HOME NEO4J_CONF
}
-
+
diff --git a/databases/neo4j/files/patch-bin_neo4j-shell b/databases/neo4j/files/patch-bin_neo4j-shell
deleted file mode 100644
index 2238d60bf4b7..000000000000
--- a/databases/neo4j/files/patch-bin_neo4j-shell
+++ /dev/null
@@ -1,37 +0,0 @@
---- bin/neo4j-shell.orig 2018-02-07 19:48:06 UTC
-+++ bin/neo4j-shell
-@@ -39,7 +39,9 @@ build_classpath() {
- detect_os() {
- if uname -s | grep -q Darwin; then
- DIST_OS="macosx"
-- elif [[ -e /etc/gentoo-release ]]; then
-+ elif uname -s | grep -q FreeBSD; then
-+ DIST_OS="freebsd"
-+ elif [[ -e /etc/gentoo-release ]]; then
- DIST_OS="gentoo"
- else
- DIST_OS="other"
-@@ -122,7 +124,10 @@ _find_java_home() {
- [[ "${JAVA_HOME:-}" ]] && return
-
- case "${DIST_OS}" in
-- "macosx")
-+ "freebsd")
-+ JAVA_HOME="%%JAVA_HOME%%"
-+ ;;
-+ "macosx")
- JAVA_HOME="$(/usr/libexec/java_home -v 1.8)"
- ;;
- "gentoo")
-@@ -138,9 +143,9 @@ _show_java_help() {
-
- _setup_calculated_paths() {
- if [[ -z "${NEO4J_HOME:-}" ]]; then
-- NEO4J_HOME="$(cd "$(dirname "$0")"/.. && pwd)"
-+ NEO4J_HOME="$(cd "$(dirname "$0")"/../neo4j && pwd)"
- fi
-- : "${NEO4J_CONF:="${NEO4J_HOME}/conf"}"
-+ : "${NEO4J_CONF:="${NEO4J_HOME}/../etc"}"
- readonly NEO4J_HOME NEO4J_CONF
- }
-
diff --git a/databases/neo4j/pkg-plist b/databases/neo4j/pkg-plist
index f24af6f6dedd..c7698be21711 100644
--- a/databases/neo4j/pkg-plist
+++ b/databases/neo4j/pkg-plist
@@ -2,94 +2,130 @@ bin/cypher-shell
bin/neo4j
bin/neo4j-admin
bin/neo4j-import
-bin/neo4j-shell
@sample etc/neo4j.conf.sample
-neo4j/lib/bcpkix-jdk15on-1.53.jar
-neo4j/lib/bcprov-jdk15on-1.53.jar
-neo4j/lib/caffeine-2.3.3.jar
-neo4j/lib/commons-compress-1.12.jar
+neo4j/lib/FastInfoset-1.2.16.jar
+neo4j/lib/WMI4Java-1.6.1.jar
+neo4j/lib/activation-1.1.1.jar
+neo4j/lib/bcpkix-jdk15on-1.68.jar
+neo4j/lib/bcprov-jdk15on-1.68.jar
+neo4j/lib/caffeine-2.6.2.jar
+neo4j/lib/commons-compress-1.19.jar
neo4j/lib/commons-configuration-1.10.jar
-neo4j/lib/commons-io-2.4.jar
+neo4j/lib/commons-io-2.6.jar
neo4j/lib/commons-lang-2.6.jar
-neo4j/lib/commons-lang3-3.5.jar
+neo4j/lib/commons-lang3-3.8.jar
neo4j/lib/commons-logging-1.1.1.jar
-neo4j/lib/commons-text-1.1.jar
+neo4j/lib/commons-text-1.4.jar
neo4j/lib/concurrentlinkedhashmap-lru-1.4.2.jar
-neo4j/lib/jackson-core-asl-1.9.13.jar
-neo4j/lib/jackson-jaxrs-1.9.13.jar
-neo4j/lib/jackson-mapper-asl-1.9.13.jar
+neo4j/lib/eclipse-collections-9.2.0.jar
+neo4j/lib/eclipse-collections-api-9.2.0.jar
+neo4j/lib/istack-commons-runtime-3.0.8.jar
+neo4j/lib/jPowerShell-1.9.jar
+neo4j/lib/jProcesses-1.6.4.jar
+neo4j/lib/jackson-annotations-2.10.5.jar
+neo4j/lib/jackson-core-2.10.5.jar
+neo4j/lib/jackson-databind-2.10.5.1.jar
+neo4j/lib/jackson-jaxrs-base-2.10.5.jar
+neo4j/lib/jackson-jaxrs-json-provider-2.10.5.jar
+neo4j/lib/jackson-module-jaxb-annotations-2.10.5.jar
+neo4j/lib/jakarta.activation-api-1.2.1.jar
+neo4j/lib/jakarta.xml.bind-api-2.3.2.jar
neo4j/lib/javax.servlet-api-3.1.0.jar
-neo4j/lib/jersey-core-1.19.jar
-neo4j/lib/jersey-multipart-1.19.jar
-neo4j/lib/jersey-server-1.19.jar
-neo4j/lib/jersey-servlet-1.19.jar
-neo4j/lib/jetty-http-9.2.22.v20170606.jar
-neo4j/lib/jetty-io-9.2.22.v20170606.jar
-neo4j/lib/jetty-security-9.2.22.v20170606.jar
-neo4j/lib/jetty-server-9.2.22.v20170606.jar
-neo4j/lib/jetty-servlet-9.2.22.v20170606.jar
-neo4j/lib/jetty-util-9.2.22.v20170606.jar
-neo4j/lib/jetty-webapp-9.2.22.v20170606.jar
-neo4j/lib/jetty-xml-9.2.22.v20170606.jar
-neo4j/lib/jline-2.12.jar
+neo4j/lib/jaxb-api-2.3.0.jar
+neo4j/lib/jaxb-runtime-2.3.2.jar
+neo4j/lib/jersey-core-1.19.3.jar
+neo4j/lib/jersey-server-1.19.3.jar
+neo4j/lib/jersey-servlet-1.19.3.jar
+neo4j/lib/jetty-http-9.4.39.v20210325.jar
+neo4j/lib/jetty-io-9.4.39.v20210325.jar
+neo4j/lib/jetty-security-9.4.39.v20210325.jar
+neo4j/lib/jetty-server-9.4.39.v20210325.jar
+neo4j/lib/jetty-servlet-9.4.39.v20210325.jar
+neo4j/lib/jetty-util-9.4.39.v20210325.jar
+neo4j/lib/jetty-webapp-9.4.39.v20210325.jar
+neo4j/lib/jetty-xml-9.4.39.v20210325.jar
neo4j/lib/jsr311-api-1.1.2.r612.jar
-neo4j/lib/lucene-analyzers-common-5.5.0.jar
-neo4j/lib/lucene-codecs-5.5.0.jar
-neo4j/lib/lucene-core-5.5.0.jar
-neo4j/lib/lucene-queryparser-5.5.0.jar
-neo4j/lib/mimepull-1.9.3.jar
+neo4j/lib/lucene-analyzers-common-5.5.5.jar
+neo4j/lib/lucene-codecs-5.5.5.jar
+neo4j/lib/lucene-core-5.5.5.jar
+neo4j/lib/lucene-queryparser-5.5.5.jar
+neo4j/lib/neo4j-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-annotation-processors-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-ast-3.5-%%DISTVERSION%%.jar
neo4j/lib/neo4j-bolt-%%DISTVERSION%%.jar
-neo4j/lib/neo4j-browser-3.1.4.jar
+neo4j/lib/neo4j-browser-4.2.5.jar
neo4j/lib/neo4j-codegen-%%DISTVERSION%%.jar
neo4j/lib/neo4j-collections-%%DISTVERSION%%.jar
neo4j/lib/neo4j-command-line-%%DISTVERSION%%.jar
neo4j/lib/neo4j-common-%%DISTVERSION%%.jar
neo4j/lib/neo4j-configuration-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-concurrent-%%DISTVERSION%%.jar
neo4j/lib/neo4j-consistency-check-%%DISTVERSION%%.jar
neo4j/lib/neo4j-csv-%%DISTVERSION%%.jar
neo4j/lib/neo4j-cypher-%%DISTVERSION%%.jar
-neo4j/lib/neo4j-cypher-compiler-2.3-2.3.11.jar
-neo4j/lib/neo4j-cypher-compiler-3.1-3.1.6.jar
-neo4j/lib/neo4j-cypher-compiler-3.2-3.2.8.jar
-neo4j/lib/neo4j-cypher-compiler-3.3-%%DISTVERSION%%.jar
-neo4j/lib/neo4j-cypher-frontend-2.3-2.3.11.jar
-neo4j/lib/neo4j-cypher-frontend-3.1-3.1.6.jar
-neo4j/lib/neo4j-cypher-frontend-3.2-3.2.8.jar
-neo4j/lib/neo4j-cypher-frontend-3.3-%%DISTVERSION%%.jar
-neo4j/lib/neo4j-cypher-ir-3.2-3.2.8.jar
-neo4j/lib/neo4j-cypher-ir-3.3-%%DISTVERSION%%.jar
-neo4j/lib/neo4j-cypher-logical-plans-3.3-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-cypher-compiler-2.3-2.3.12.jar
+neo4j/lib/neo4j-cypher-compiler-3.1-3.1.9.jar
+neo4j/lib/neo4j-cypher-expression-3.4-3.4.18.jar
+neo4j/lib/neo4j-cypher-expression-evaluator-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-cypher-frontend-2.3-2.3.12.jar
+neo4j/lib/neo4j-cypher-frontend-3.1-3.1.9.jar
+neo4j/lib/neo4j-cypher-interpreted-runtime-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-cypher-ir-3.4-3.4.18.jar
+neo4j/lib/neo4j-cypher-ir-3.5-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-cypher-logical-plans-3.4-3.4.18.jar
+neo4j/lib/neo4j-cypher-logical-plans-3.5-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-cypher-planner-3.4-3.4.18.jar
+neo4j/lib/neo4j-cypher-planner-3.5-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-cypher-planner-spi-3.4-3.4.18.jar
+neo4j/lib/neo4j-cypher-planner-spi-3.5-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-cypher-runtime-util-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-cypher-util-3.4-3.4.18.jar
+neo4j/lib/neo4j-data-collector-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-diagnostics-%%DISTVERSION%%.jar
neo4j/lib/neo4j-dbms-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-expressions-3.5-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-front-end-3.5-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-fulltext-index-%%DISTVERSION%%.jar
neo4j/lib/neo4j-graph-algo-%%DISTVERSION%%.jar
-neo4j/lib/neo4j-graph-matching-3.1.6.jar
+neo4j/lib/neo4j-graph-matching-3.1.9.jar
neo4j/lib/neo4j-graphdb-api-%%DISTVERSION%%.jar
neo4j/lib/neo4j-import-tool-%%DISTVERSION%%.jar
neo4j/lib/neo4j-index-%%DISTVERSION%%.jar
neo4j/lib/neo4j-io-%%DISTVERSION%%.jar
neo4j/lib/neo4j-jmx-%%DISTVERSION%%.jar
neo4j/lib/neo4j-kernel-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-kernel-api-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-legacy-%%DISTVERSION%%.jar
neo4j/lib/neo4j-logging-%%DISTVERSION%%.jar
neo4j/lib/neo4j-lucene-index-%%DISTVERSION%%.jar
neo4j/lib/neo4j-lucene-upgrade-%%DISTVERSION%%.jar
-neo4j/lib/neo4j-primitive-collections-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-parser-3.5-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-procedure-api-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-push-to-cloud-%%DISTVERSION%%.jar
neo4j/lib/neo4j-resource-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-rewriting-3.5-%%DISTVERSION%%.jar
neo4j/lib/neo4j-security-%%DISTVERSION%%.jar
neo4j/lib/neo4j-server-%%DISTVERSION%%.jar
-neo4j/lib/neo4j-shell-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-spatial-index-%%DISTVERSION%%.jar
neo4j/lib/neo4j-ssl-%%DISTVERSION%%.jar
neo4j/lib/neo4j-udc-%%DISTVERSION%%.jar
neo4j/lib/neo4j-unsafe-%%DISTVERSION%%.jar
+neo4j/lib/neo4j-util-3.5-%%DISTVERSION%%.jar
neo4j/lib/neo4j-values-%%DISTVERSION%%.jar
-neo4j/lib/netty-all-4.1.17.Final.jar
+neo4j/lib/netty-all-4.1.48.Final.jar
+neo4j/lib/openCypher-frontend-1-3.4.18.jar
neo4j/lib/opencsv-2.3.jar
neo4j/lib/parboiled-core-1.1.7.jar
neo4j/lib/parboiled-scala_2.11-1.1.7.jar
-neo4j/lib/rhino-1.7R4.jar
neo4j/lib/scala-library-2.11.12.jar
neo4j/lib/scala-reflect-2.11.12.jar
-neo4j/lib/server-api-3.3.2.jar
+neo4j/lib/server-api-%%DISTVERSION%%.jar
+neo4j/lib/stax-ex-1.8.1.jar
+neo4j/lib/txw2-2.3.2.jar
+neo4j/lib/zstd-jni-1.3.8-6.jar
+neo4j/lib/zstd-proxy-%%DISTVERSION%%.jar
neo4j/libexec/tools/2.x-config-migrator.jar
-neo4j/libexec/tools/cypher-shell-all.jar
+neo4j/libexec/tools/cypher-shell.jar
@dir neo4j/lib/plugins
@dir %%DBDIR%%
@dir etc/neo4j-certificates