summaryrefslogtreecommitdiff
path: root/databases/pear-DB_Table
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /databases/pear-DB_Table
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadfreebsd-ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Diffstat (limited to 'databases/pear-DB_Table')
-rw-r--r--databases/pear-DB_Table/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/pear-DB_Table/Makefile b/databases/pear-DB_Table/Makefile
index bf6db912c4c3..24419c95558a 100644
--- a/databases/pear-DB_Table/Makefile
+++ b/databases/pear-DB_Table/Makefile
@@ -17,8 +17,8 @@ PEAR_HTML_QUICKFORM_DESC= PEAR::HTML_QuickForm support
PEAR_DB_DESC= PEAR::DB support
PEAR_MDB2_DESC= PEAR::MDB2 support
-PEAR_HTML_QUICKFORM_RUN_DEPENDS= ${PEARDIR}/HTML/QuickForm.php:devel/pear-HTML_QuickForm
-PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB
-PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:databases/pear-MDB2
+PEAR_HTML_QUICKFORM_RUN_DEPENDS= ${PEARDIR}/HTML/QuickForm.php:devel/pear-HTML_QuickForm@${PHP_FLAVOR}
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB@${PHP_FLAVOR}
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR}
.include <bsd.port.mk>