summaryrefslogtreecommitdiff
path: root/databases/memcached
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-24 13:32:58 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-24 13:32:58 +0000
commitb5646534525f3eb9cce485f6580fe9a473ce2ba7 (patch)
treeffddb673c48038e781d69f6c3d08ec8855ad33a5 /databases/memcached
parentafee9d5cd365a4ef10c99ef86e5358e76a5d37f2 (diff)
downloadfreebsd-ports-b5646534525f3eb9cce485f6580fe9a473ce2ba7.zip
Only use libevent2
Remove libevent as libevent2 is providing a good compatibility interface as well as providing better performances. Remove custom patches from libevent2 and install libevent2 the regular way Mark ports abusing private fields of the libevent1 API as broken Import a patch from fedora to have honeyd working with libevent2 Remove most of the patches necessary to find the custom installation we used to have for libevent2 With hat: portmgr
Diffstat (limited to 'databases/memcached')
-rw-r--r--databases/memcached/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/databases/memcached/Makefile b/databases/memcached/Makefile
index f0ffc1802bbe..86ffccab853b 100644
--- a/databases/memcached/Makefile
+++ b/databases/memcached/Makefile
@@ -3,7 +3,7 @@
PORTNAME= memcached
PORTVERSION= 1.4.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
${MASTER_SITE_GENTOO}
@@ -15,7 +15,7 @@ COMMENT= High-performance distributed memory object cache system
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libevent-2.0.so:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
CONFLICTS= memcached-1.2*
@@ -34,11 +34,10 @@ SHEBANG_FILES= scripts/memcached-tool
USE_CSTD= c99
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libevent=${LOCALBASE}/lib/event2 --program-prefix= \
+CONFIGURE_ARGS= --with-libevent=${LOCALBASE} --program-prefix= \
--disable-coverage
CFLAGS+= -fstack-protector \
- -I${LOCALBASE}/include/event2/compat \
-I${LOCALBASE}/include
DTRACE_CONFIGURE_ENABLE= dtrace
@@ -63,9 +62,6 @@ BROKEN= DTRACE broken with gcc/clang - reported upstream
BUILD_DEPENDS= xml2rfc:${PORTSDIR}/textproc/xml2rfc
.endif
-post-patch:
- @${REINPLACE_CMD} -e "s,-levent,-levent-2.0,g" ${WRKSRC}/configure
-
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/memcached-tool ${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}