summaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-01-25 20:19:38 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-01-25 20:19:38 +0000
commit93eea426e87f4ad07ba7751dea5dbff00744b015 (patch)
treea930492ad4894bbd691e092a984bbf3558e1feb8 /comms
parentcf769d83efdb558f7179371d422b9a4f723b9697 (diff)
downloadfreebsd-ports-93eea426e87f4ad07ba7751dea5dbff00744b015.zip
misc/qtchooser: do not create unnecessary wrappers
misc/qtchooser provides a wrapper binary bin/qtchooser, that when called with name foo, will lauch the corresponding binary from lib/qt${current_qt_version}/bin/foo. Previously qtchooser would install a list of 30-ish symlinks to itself automatically. Now we switch this around. qt-dist ports that define QT_BINARIES will now have a @postexec and @postunexec entry added to their plist to run the shell-script update-qtchooser-wrapper (installed by qtchooser). update-qtchooser-wrapper removes all symlinks to bin/qtcreator that have no corresponding binary in lib/qt*/bin, and readds links that are missing. Exp-run by: antoine PR: 242905 PR: 243443 Reported by: grarpamp@gmail.com Reviewed by: adridg Differential Revision: https://reviews.freebsd.org/D22991
Diffstat (limited to 'comms')
-rw-r--r--comms/qt5-serialbus/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/comms/qt5-serialbus/Makefile b/comms/qt5-serialbus/Makefile
index aeccbf4933ae..c95fda8eb6d3 100644
--- a/comms/qt5-serialbus/Makefile
+++ b/comms/qt5-serialbus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= serialbus
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
@@ -11,5 +12,6 @@ COMMENT= Qt functions to access industrial bus systems
USES= compiler:c++11-lib qmake qt-dist:5,serialbus
USE_QT= core network serialport buildtools_build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+QT_BINARIES= yes
.include <bsd.port.mk>