summaryrefslogtreecommitdiff
path: root/comms/uhd/files/patch-host_cmake_Modules_UHDAtomics.cmake
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2022-05-30 18:40:46 +0200
committerMichael Reifenberger <mr@FreeBSD.org>2022-05-30 18:41:57 +0200
commitd61850c69106c7f452d962cde7f21dd04e94f678 (patch)
treea65915be2b4c1d3c5f562cd4eeb1f14c1ce1335e /comms/uhd/files/patch-host_cmake_Modules_UHDAtomics.cmake
parentfced1bd5b4201106b4c6a2832530b1256c0c8b99 (diff)
downloadfreebsd-ports-d61850c69106c7f452d962cde7f21dd04e94f678.zip
comms/uhd: Fix pkg-plist and update
Try to unbreak the build and update to 4.2.0.0
Diffstat (limited to 'comms/uhd/files/patch-host_cmake_Modules_UHDAtomics.cmake')
-rw-r--r--comms/uhd/files/patch-host_cmake_Modules_UHDAtomics.cmake15
1 files changed, 15 insertions, 0 deletions
diff --git a/comms/uhd/files/patch-host_cmake_Modules_UHDAtomics.cmake b/comms/uhd/files/patch-host_cmake_Modules_UHDAtomics.cmake
new file mode 100644
index 000000000000..ef5f6f1b90be
--- /dev/null
+++ b/comms/uhd/files/patch-host_cmake_Modules_UHDAtomics.cmake
@@ -0,0 +1,15 @@
+--- host/cmake/Modules/UHDAtomics.cmake.orig 2022-05-30 13:45:17 UTC
++++ host/cmake/Modules/UHDAtomics.cmake
+@@ -102,9 +102,9 @@ macro(CHECK_ATOMICS_LIB_REQUIRED required_var)
+ message(FATAL_ERROR "Host compiler must support std::atomic!")
+ endif()
+ else()
+- message(
+- FATAL_ERROR
+- "Boost appears to require libatomic, but cannot find it.")
++ # message(
++ # FATAL_ERROR
++ # "Boost appears to require libatomic, but cannot find it.")
+ endif()
+ endif()
+ endif()