summaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2019-04-06 21:06:49 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2019-04-06 21:06:49 +0000
commita7a2d3a5aaef358006c57a1e2f0eb27e42be2529 (patch)
treea24d578e6bba76404baacfd86638a3fa16c4d352 /cad
parente7fa3828e1aaa6f9483ec18f280d56382453634d (diff)
downloadfreebsd-ports-a7a2d3a5aaef358006c57a1e2f0eb27e42be2529.zip
cad/openvsp: update to 3.17.0
From the ChangeLog: (http://openvsp.org/blogs/announcements/2019/03/28/openvsp-3-17-0-released) Features: * CHARM Python export scripts * Transparent screenshots * Border toggle in menu * Improved show axis toggle * Export structure surfaces to IGES and STEP * Design lift coefficient support for four-digit airfoils * Propeller definition by thickness and CLi distribution * Calculate integrated design lift coefficient for props * BEM files in terms of thickness and CLi distribution * Feather axis and offset control for propeller * Implicit disk model for propeller * STL solid names include tag number * Tag unintersected triangles for STL export * Increase tessellation limits * Option to export props at origin (unintersected STL and STEP/IGES) * Batch evaluation of Bezier surface points and normals (faster refresh) Fixes: * Restore visualization of CFDMesh sources and wake * Don't crash when BOR XSec changed to Bezier * Don't crash when reading Lednicer airfoils * Import v2 multi-section wings properly * Make key-corner default for rounded rectangle * Reverse props with shifted construction line built correctly * Don't allow insertion of XSec at negative index from API * Don't allow comma as decimal point marker; fixes file corruption. * Fix writing excressence drag label to XML file * Fix unexpected ResetRemapID in files with conformal geometry
Diffstat (limited to 'cad')
-rw-r--r--cad/openvsp/Makefile3
-rw-r--r--cad/openvsp/distinfo6
-rw-r--r--cad/openvsp/files/patch-src_util_FileUtil.cpp31
3 files changed, 35 insertions, 5 deletions
diff --git a/cad/openvsp/Makefile b/cad/openvsp/Makefile
index 7a697837012c..96ace9052c14 100644
--- a/cad/openvsp/Makefile
+++ b/cad/openvsp/Makefile
@@ -2,8 +2,7 @@
PORTNAME= openvsp
DISTVERSIONPREFIX= ${GH_PROJECT}_
-DISTVERSION= 3.16.2
-PORTREVISION= 2
+DISTVERSION= 3.17.0
CATEGORIES= cad
MAINTAINER= fernape@FreeBSD.org
diff --git a/cad/openvsp/distinfo b/cad/openvsp/distinfo
index 0bd5f6088bde..96204fdf3fbe 100644
--- a/cad/openvsp/distinfo
+++ b/cad/openvsp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1542557819
-SHA256 (OpenVSP-OpenVSP-OpenVSP_3.16.2_GH0.tar.gz) = dc7b482651d4274078860a9f750037e0060f9e7343122c2ca14b73aca281bacf
-SIZE (OpenVSP-OpenVSP-OpenVSP_3.16.2_GH0.tar.gz) = 34458283
+TIMESTAMP = 1553966825
+SHA256 (OpenVSP-OpenVSP-OpenVSP_3.17.0_GH0.tar.gz) = ba34eb172d767503cf7e6434225a831662ab48c6a4707ed3fdc4af7ee4343646
+SIZE (OpenVSP-OpenVSP-OpenVSP_3.17.0_GH0.tar.gz) = 35052877
diff --git a/cad/openvsp/files/patch-src_util_FileUtil.cpp b/cad/openvsp/files/patch-src_util_FileUtil.cpp
new file mode 100644
index 000000000000..75365e74e79e
--- /dev/null
+++ b/cad/openvsp/files/patch-src_util_FileUtil.cpp
@@ -0,0 +1,31 @@
+--- src/util/FileUtil.cpp.orig 2019-03-28 20:30:27 UTC
++++ src/util/FileUtil.cpp
+@@ -19,7 +19,9 @@
+ #include <pwd.h>
+ #endif
+
++#include <libgen.h>
+
++
+ vector< string > ScanFolder( const char* dir_path )
+ {
+ vector< string > file_vec;
+@@ -107,9 +109,18 @@ bail:
+
+ string PathToExe()
+ {
++
+ int bufsize = 255;
+ char *path = NULL;
+ bool done = false;
++
++ char temp[PATH_MAX];
++ char exepath[PATH_MAX];
++
++ ::snprintf(temp, sizeof(temp),"/proc/curproc/file");
++ ::realpath(temp, exepath);
++
++ return dirname(exepath);
+
+ // Pre-loop initialization.
+ #ifdef WIN32