summaryrefslogtreecommitdiff
path: root/cad/pdnmesh
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 14:53:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 14:53:20 +0000
commita327ff430ab824a5e8342f6a95e1d749c043e5de (patch)
tree29243a947e6109dbf0500a80dd52284f80f4b0aa /cad/pdnmesh
parenta2275161bdf38678974bb793dfe3195fe1950aab (diff)
downloadfreebsd-ports-a327ff430ab824a5e8342f6a95e1d749c043e5de.zip
In preparation for making libtool generate libraries with a sane name, fix all
LIB_DEPENDS in cad With hat: portmgr
Diffstat (limited to 'cad/pdnmesh')
-rw-r--r--cad/pdnmesh/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/cad/pdnmesh/Makefile b/cad/pdnmesh/Makefile
index 1da7cbd283af..e7a4f8adb7bf 100644
--- a/cad/pdnmesh/Makefile
+++ b/cad/pdnmesh/Makefile
@@ -12,15 +12,15 @@ COMMENT= Mesh generator and solver for Finite Element problems
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- cairo:${PORTSDIR}/graphics/cairo \
- drm:${PORTSDIR}/graphics/libdrm \
- png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- gtkglext:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libcairo.so:${PORTSDIR}/graphics/cairo \
+ libdrm.so:${PORTSDIR}/graphics/libdrm \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libgtkglext.so:${PORTSDIR}/x11-toolkits/gtkglext
OPTIONS_DEFINE= ATLAS DOCS EXAMPLES
ATLAS_DESC= Enable ATLAS support
@@ -45,11 +45,11 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MATLAS}
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
CONFIGURE_ARGS+=--with-blas=cblas --with-lapack=alapack
.else
-LIB_DEPENDS+= blas:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
CONFIGURE_ARGS+=--with-blas=blas --with-lapack=lapack
.endif