summaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-26 14:39:02 -0700
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-26 15:25:21 -0700
commitbe2fb2f2905d13d5f2463688dbf319f5940cfccc (patch)
treed7fa7fae4c4b5e95f22504a6b7d2aa31da1eb68b /biology
parent87e5be8f70b9c813c621ee7f4b13a18250b8cdf5 (diff)
downloadfreebsd-ports-be2fb2f2905d13d5f2463688dbf319f5940cfccc.zip
biology/unikmer: New port: Toolkit for nucleic acid k-mer analysis, set operations on k-mers
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/unikmer/Makefile19
-rw-r--r--biology/unikmer/distinfo5
-rw-r--r--biology/unikmer/pkg-descr12
4 files changed, 37 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index e5bec235ca01..38761df9c785 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -185,6 +185,7 @@
SUBDIR += trimmomatic
SUBDIR += ucsc-userapps
SUBDIR += ugene
+ SUBDIR += unikmer
SUBDIR += vcf-split
SUBDIR += vcf2hap
SUBDIR += vcflib
diff --git a/biology/unikmer/Makefile b/biology/unikmer/Makefile
new file mode 100644
index 000000000000..fa7eec68c77b
--- /dev/null
+++ b/biology/unikmer/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= unikmer
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.18.0
+CATEGORIES= biology
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Toolkit for nucleic acid k-mer analysis, set operations on k-mers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/shenwei356/unikmer
+GO_TARGET= ./${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/biology/unikmer/distinfo b/biology/unikmer/distinfo
new file mode 100644
index 000000000000..934330ac60cd
--- /dev/null
+++ b/biology/unikmer/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1622064837
+SHA256 (go/biology_unikmer/unikmer-v0.18.0/v0.18.0.mod) = 6ccade17e0fdfc86ebaa0683f7aab4e3c94019032e0d0f4c78bf957a2a8f9c1b
+SIZE (go/biology_unikmer/unikmer-v0.18.0/v0.18.0.mod) = 881
+SHA256 (go/biology_unikmer/unikmer-v0.18.0/v0.18.0.zip) = ff1d28fc6c79d62fc1a240bec03acc604f9ef7375f22548e0cc472c41b5b349d
+SIZE (go/biology_unikmer/unikmer-v0.18.0/v0.18.0.zip) = 4273162
diff --git a/biology/unikmer/pkg-descr b/biology/unikmer/pkg-descr
new file mode 100644
index 000000000000..7ae41bf53489
--- /dev/null
+++ b/biology/unikmer/pkg-descr
@@ -0,0 +1,12 @@
+unikmer is a golang package and a toolkit for nucleic acid k-mer analysis,
+providing functions including set operation k-mers (sketch) optional with TaxIds
+but without count information.
+
+K-mers are either encoded (k<=32) or hashed (arbitrary k) into uint64, and
+serialized in binary file with extension .unik.
+
+TaxIds can be assigned when counting k-mers from genome sequences, and LCA
+(Lowest Common Ancestor) is computed during set opertions including computing
+union, intersecton, set difference, unique and repeated k-mers.
+
+WWW: https://github.com/shenwei356/unikmer