summaryrefslogtreecommitdiff
path: root/biology/htslib
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-12-25 01:31:09 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-12-25 01:31:09 +0000
commitd5dffd3623cd884ee63d538b9b7b8772b317ff7a (patch)
tree001d1d79fceac21fd776f909dd516ba43731ff84 /biology/htslib
parent19dd31f478c4dde12ae1cd48ca92303b9da20d78 (diff)
downloadfreebsd-ports-d5dffd3623cd884ee63d538b9b7b8772b317ff7a.zip
biology/{bcftools,htslib,samtools}: update 1.2.x -> 1.3
- Update ports to 1.3 and set BUILD_DEPENDS of dependent ports to require version 1.3 of htslib. - Add CURL option to htslib - Add TEST_TARGET with perl and bash dependencies for testing - Tidy up spacing and pkg-message's PR: 205524 PR: 205525 PR: 205526 Submitted by: cartwright@asu.edu (maintainer)
Diffstat (limited to 'biology/htslib')
-rw-r--r--biology/htslib/Makefile23
-rw-r--r--biology/htslib/distinfo4
-rw-r--r--biology/htslib/files/patch-Makefile27
-rw-r--r--biology/htslib/files/patch-configure.ac4
-rw-r--r--biology/htslib/files/patch-cram_cram__io.c10
-rw-r--r--biology/htslib/files/patch-hfile__libcurl.c14
-rw-r--r--biology/htslib/pkg-plist2
7 files changed, 52 insertions, 32 deletions
diff --git a/biology/htslib/Makefile b/biology/htslib/Makefile
index ad57169abdd2..b6532c2d21b8 100644
--- a/biology/htslib/Makefile
+++ b/biology/htslib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= htslib
-PORTVERSION= 1.2.1
+PORTVERSION= 1.3
CATEGORIES= biology devel
MAINTAINER= cartwright@asu.edu
@@ -12,13 +12,26 @@ LICENSE= BSD3CLAUSE MIT
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE
+TEST_DEPENDS= bash:${PORTSDIR}/shells/bash
+
USE_GITHUB= yes
GH_ACCOUNT= samtools
-USES= gmake
+USES= autoreconf gmake perl5 shebangfix
+USE_PERL5= test
USE_LDCONFIG= yes
-USE_AUTOTOOLS= autoconf
-GNU_CONFIGURE=yes
+GNU_CONFIGURE= yes
+SHEBANG_FILES= test/compare_sam.pl test/test.pl test/test_view.pl
+
+OPTIONS_DEFINE= CURL
+OPTIONS_DEFAULT= CURL
+
+CURL_DESC= Use libcurl for network file access (HTTPS and S3 support).
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+CURL_CONFIGURE_ENABLE= libcurl
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
INSTALL_DATA="${INSTALL_DATA}" \
@@ -27,6 +40,8 @@ MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
PLIST_SUB= PORTVERSION="${PORTVERSION}"
+TEST_TARGET= test
+
post-patch:
@${REINPLACE_CMD} -e 's|@PORTVERSION@|${PORTVERSION}|g' ${WRKSRC}/configure.ac
diff --git a/biology/htslib/distinfo b/biology/htslib/distinfo
index 15bc94bb0b48..434c3ff8cc00 100644
--- a/biology/htslib/distinfo
+++ b/biology/htslib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (samtools-htslib-1.2.1_GH0.tar.gz) = 4f67f0fc73ae86f3ed4336d8d8f6da3c12066e9cb5f142b685622dd6b8f9ae42
-SIZE (samtools-htslib-1.2.1_GH0.tar.gz) = 997625
+SHA256 (samtools-htslib-1.3_GH0.tar.gz) = 291a54090df3bc367b509890e1cfa34d53b1ee9be42c5fa6c2b1e2ec8f8b13af
+SIZE (samtools-htslib-1.3_GH0.tar.gz) = 1042953
diff --git a/biology/htslib/files/patch-Makefile b/biology/htslib/files/patch-Makefile
index 83da01f7e5e7..cb35c2f0f055 100644
--- a/biology/htslib/files/patch-Makefile
+++ b/biology/htslib/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2015-02-03 16:22:23 UTC
+--- Makefile.orig 2015-12-15 16:34:33 UTC
+++ Makefile
-@@ -22,16 +22,9 @@
+@@ -22,16 +22,7 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
# DEALINGS IN THE SOFTWARE.
@@ -8,19 +8,18 @@
-AR = ar
-RANLIB = ranlib
-
--CPPFLAGS = -I.
-+CPPFLAGS += -I.
- # TODO: probably update cram code to make it compile cleanly with -Wc++-compat
+-CPPFLAGS =
+-# TODO: probably update cram code to make it compile cleanly with -Wc++-compat
-CFLAGS = -g -Wall -O2
EXTRA_CFLAGS_PIC = -fpic
-LDFLAGS =
--LDLIBS =
+-LIBS =
# For now these don't work too well as samtools also needs to know to
# add -lbz2 and -llzma if linking against the static libhts.a library.
-@@ -57,16 +50,10 @@ bindir = $(exec_prefix)/bin
- includedir = $(prefix)/include
+@@ -58,16 +49,10 @@ includedir = $(prefix)/include
libdir = $(exec_prefix)/lib
+ libexecdir = $(exec_prefix)/libexec
datarootdir = $(prefix)/share
-mandir = $(datarootdir)/man
+mandir = $(prefix)/man
@@ -35,18 +34,18 @@
-INSTALL_DIR = $(MKDIR_P) -m 755
+pkgconfigdir= $(exec_prefix)/libdata/pkgconfig
- BUILT_PROGRAMS = \
- bgzip \
-@@ -82,7 +69,7 @@ BUILT_TEST_PROGRAMS = \
+ # Set by config.mk if plugins are enabled
+ plugindir =
+@@ -86,7 +71,7 @@ BUILT_TEST_PROGRAMS = \
test/test-vcf-api \
test/test-vcf-sweep
--all: lib-static lib-shared $(BUILT_PROGRAMS) $(BUILT_TEST_PROGRAMS)
-+all: lib-static lib-shared $(BUILT_PROGRAMS)
+-all: lib-static lib-shared $(BUILT_PROGRAMS) plugins $(BUILT_TEST_PROGRAMS)
++all: lib-static lib-shared $(BUILT_PROGRAMS) plugins
HTSPREFIX =
include htslib_vars.mk
-@@ -332,7 +319,7 @@ installdirs:
+@@ -361,7 +346,7 @@ installdirs:
# and libhts.so.NN (used by client executables at runtime).
install-so: libhts.so installdirs
diff --git a/biology/htslib/files/patch-configure.ac b/biology/htslib/files/patch-configure.ac
index 7e5a1a6363bc..8e1d8bc9ea64 100644
--- a/biology/htslib/files/patch-configure.ac
+++ b/biology/htslib/files/patch-configure.ac
@@ -1,11 +1,11 @@
---- configure.ac.orig 2015-02-03 16:22:23 UTC
+--- configure.ac.orig 2015-12-15 16:34:33 UTC
+++ configure.ac
@@ -23,7 +23,7 @@
# DEALINGS IN THE SOFTWARE.
dnl Process this file with autoconf to produce a configure script
-AC_INIT([HTSlib], m4_esyscmd_s([make print-version]),
-+AC_INIT([HTSlib], [@PORTVERSION@],
++AC_INIT([HTSlib], [1.3],
[samtools-help@lists.sourceforge.net], [], [http://www.htslib.org/])
AC_PREREQ(2.63) dnl This version introduced 4-argument AC_CHECK_HEADER
AC_CONFIG_SRCDIR(hts.c)
diff --git a/biology/htslib/files/patch-cram_cram__io.c b/biology/htslib/files/patch-cram_cram__io.c
deleted file mode 100644
index 68121b22c41b..000000000000
--- a/biology/htslib/files/patch-cram_cram__io.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- cram/cram_io.c.orig 2015-02-03 16:22:23 UTC
-+++ cram/cram_io.c
-@@ -53,6 +53,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- #include <assert.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <unistd.h>
- #include <zlib.h>
- #ifdef HAVE_LIBBZ2
- #include <bzlib.h>
diff --git a/biology/htslib/files/patch-hfile__libcurl.c b/biology/htslib/files/patch-hfile__libcurl.c
new file mode 100644
index 000000000000..449debeade28
--- /dev/null
+++ b/biology/htslib/files/patch-hfile__libcurl.c
@@ -0,0 +1,14 @@
+--- hfile_libcurl.c.orig 2015-12-22 22:35:42 UTC
++++ hfile_libcurl.c
+@@ -39,6 +39,11 @@ DEALINGS IN THE SOFTWARE. */
+
+ #include <curl/curl.h>
+
++#include <sys/param.h>
++#if defined(__FreeBSD__) && (__FreeBSD_version < 1000033) && !defined(ENOTRECOVERABLE)
++# define ENOTRECOVERABLE EIO
++#endif
++
+ typedef struct {
+ hFILE base;
+ CURL *easy;
diff --git a/biology/htslib/pkg-plist b/biology/htslib/pkg-plist
index 6168f521bc8f..37233cb78fab 100644
--- a/biology/htslib/pkg-plist
+++ b/biology/htslib/pkg-plist
@@ -2,10 +2,12 @@ bin/bgzip
bin/htsfile
bin/tabix
include/htslib/bgzf.h
+include/htslib/cram.h
include/htslib/faidx.h
include/htslib/hfile.h
include/htslib/hts.h
include/htslib/hts_defs.h
+include/htslib/kbitset.h
include/htslib/kfunc.h
include/htslib/khash.h
include/htslib/khash_str2int.h