summaryrefslogtreecommitdiff
path: root/biology/htslib
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-03-20 17:14:32 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-03-20 17:14:32 +0000
commit6f516a8acf5122668b71a77d90e28cff1c3881e4 (patch)
tree74aa85b99a6dcff8050252330fb33340525ae72e /biology/htslib
parent1131956c47169cc9ba0e0809795e7021de6e7b3c (diff)
downloadfreebsd-ports-6f516a8acf5122668b71a77d90e28cff1c3881e4.zip
biology/htslib: Update to 1.12
biology/samtools: Update to 1.12 biology/bcftools: Update to 1.12 Numerous enhancements, performance improvements, and bug fixes since 1.11 Build-tested all other htslib dependents, no revbumps should be needed Reported by: portscout
Diffstat (limited to 'biology/htslib')
-rw-r--r--biology/htslib/Makefile8
-rw-r--r--biology/htslib/distinfo6
-rw-r--r--biology/htslib/files/patch-Makefile18
-rw-r--r--biology/htslib/files/patch-hfile__libcurl.c24
-rw-r--r--biology/htslib/files/patch-sam.c10
-rw-r--r--biology/htslib/pkg-plist3
6 files changed, 13 insertions, 56 deletions
diff --git a/biology/htslib/Makefile b/biology/htslib/Makefile
index 733ec0c41dea..17779dfd3503 100644
--- a/biology/htslib/Makefile
+++ b/biology/htslib/Makefile
@@ -2,8 +2,10 @@
# $FreeBSD$
PORTNAME= htslib
-DISTVERSION= 1.11.0
+DISTVERSION= 1.12
CATEGORIES= biology devel
+# Github generated distfiles are incomplete, so use custom tarball
+MASTER_SITES= https://github.com/samtools/htslib/releases/download/${DISTVERSION}/
MAINTAINER= jwb@FreeBSD.org
COMMENT= C library for high-throughput sequencing data formats
@@ -15,12 +17,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libdeflate.so:archivers/libdeflate
TEST_DEPENDS= bash:shells/bash
-USES= autoreconf gmake localbase pathfix perl5 shebangfix
-USE_GITHUB= yes
+USES= autoreconf gmake localbase pathfix perl5 shebangfix tar:bzip2
USE_PERL5= test
USE_LDCONFIG= yes
-GH_ACCOUNT= samtools
GNU_CONFIGURE= yes
PATHFIX_MAKEFILEIN= Makefile
SHEBANG_FILES= test/*.pl
diff --git a/biology/htslib/distinfo b/biology/htslib/distinfo
index ef59ac4df246..2bc449b5deb6 100644
--- a/biology/htslib/distinfo
+++ b/biology/htslib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1602982298
-SHA256 (samtools-htslib-1.11.0_GH0.tar.gz) = 55356e78f25a20194488d94308335f409c3757101398961388caf38d3cce12dd
-SIZE (samtools-htslib-1.11.0_GH0.tar.gz) = 1485848
+TIMESTAMP = 1616112272
+SHA256 (htslib-1.12.tar.bz2) = 2280141b46e953ba4ae01b98335a84f8e6ccbdb6d5cdbab7f70ee4f7e3b6f4ca
+SIZE (htslib-1.12.tar.bz2) = 4094458
diff --git a/biology/htslib/files/patch-Makefile b/biology/htslib/files/patch-Makefile
index 6f8216bbc7bb..7f91465d2ccd 100644
--- a/biology/htslib/files/patch-Makefile
+++ b/biology/htslib/files/patch-Makefile
@@ -1,16 +1,6 @@
---- Makefile.orig 2020-10-18 00:44:56 UTC
+--- Makefile.orig 2021-03-20 15:53:14 UTC
+++ Makefile
-@@ -40,7 +40,8 @@ EXTRA_CFLAGS_PIC = -fpic
- LDFLAGS = -fvisibility=hidden
- LIBS = $(htslib_default_libs)
-
--prefix = /usr/local
-+PREFIX ?= /usr/local
-+prefix = $(PREFIX)
- exec_prefix = $(prefix)
- bindir = $(exec_prefix)/bin
- includedir = $(prefix)/include
-@@ -53,13 +54,14 @@ man5dir = $(mandir)/man5
+@@ -53,13 +53,14 @@ man5dir = $(mandir)/man5
man7dir = $(mandir)/man7
pkgconfigdir= $(prefix)/libdata/pkgconfig
@@ -32,7 +22,7 @@
# Set by config.mk if plugins are enabled
plugindir =
-@@ -100,7 +102,7 @@ BUILT_THRASH_PROGRAMS = \
+@@ -102,7 +103,7 @@ BUILT_THRASH_PROGRAMS = \
test/thrash_threads6 \
test/thrash_threads7
@@ -40,4 +30,4 @@
+all: lib-static lib-shared $(BUILT_PROGRAMS) plugins \
htslib_static.mk htslib-uninstalled.pc
- HTSPREFIX =
+ ALL_CPPFLAGS = -I. $(CPPFLAGS)
diff --git a/biology/htslib/files/patch-hfile__libcurl.c b/biology/htslib/files/patch-hfile__libcurl.c
deleted file mode 100644
index 2406056b1c04..000000000000
--- a/biology/htslib/files/patch-hfile__libcurl.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- hfile_libcurl.c.orig 2020-09-22 12:15:49 UTC
-+++ hfile_libcurl.c
-@@ -22,6 +22,10 @@ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR O
- FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
- DEALINGS IN THE SOFTWARE. */
-
-+#ifndef ENOTRECOVERABLE
-+#define ENOTRECOVERABLE EIO
-+#endif
-+
- #define HTS_BUILDING_LIBRARY // Enables HTSLIB_EXPORT, see htslib/hts_defs.h
- #include <config.h>
-
-@@ -73,6 +77,10 @@ typedef struct {
- unsigned int num;
- unsigned int size;
- } hdrlist;
-+
-+#ifndef ENOTRECOVERABLE
-+#define ENOTRECOVERABLE EIO
-+#endif
-
- typedef struct {
- hdrlist fixed; // List of headers supplied at hopen()
diff --git a/biology/htslib/files/patch-sam.c b/biology/htslib/files/patch-sam.c
deleted file mode 100644
index 679b4d71967d..000000000000
--- a/biology/htslib/files/patch-sam.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- sam.c.orig 2020-10-18 00:50:46 UTC
-+++ sam.c
-@@ -35,6 +35,7 @@ DEALINGS IN THE SOFTWARE. */
- #include <assert.h>
- #include <signal.h>
- #include <inttypes.h>
-+#include <unistd.h> // usleep()
-
- // Suppress deprecation message for cigar_tab, which we initialise
- #include "htslib/hts_defs.h"
diff --git a/biology/htslib/pkg-plist b/biology/htslib/pkg-plist
index 06e7972133d5..e2ebe3a2e8d6 100644
--- a/biology/htslib/pkg-plist
+++ b/biology/htslib/pkg-plist
@@ -8,6 +8,7 @@ include/htslib/hfile.h
include/htslib/hts.h
include/htslib/hts_defs.h
include/htslib/hts_endian.h
+include/htslib/hts_expr.h
include/htslib/hts_log.h
include/htslib/hts_os.h
include/htslib/kbitset.h
@@ -30,7 +31,7 @@ include/htslib/vcf_sweep.h
include/htslib/vcfutils.h
lib/libhts.a
lib/libhts.so
-lib/libhts.so.1.11
+lib/libhts.so.%%PORTVERSION%%
lib/libhts.so.3
libdata/pkgconfig/htslib.pc
man/man1/bgzip.1.gz