summaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-06-25 18:12:21 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-06-25 18:12:21 +0000
commitbdd332142a46bba87c230cebfa85591cbd6f91fa (patch)
treef9cc12d7a713cb8aed7299a0c924df6cd6f27c80 /audio
parent9f0519ee4c03b0d897b355dd514361070eb6642f (diff)
downloadfreebsd-ports-bdd332142a46bba87c230cebfa85591cbd6f91fa.zip
Import audio/libsoxr, a sample-rate conversion library
PR: liangtai.s16@gmail.com Reviewed by: riggs
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libsoxr/Makefile61
-rw-r--r--audio/libsoxr/distinfo3
-rw-r--r--audio/libsoxr/files/FFTPAK_license.txt36
-rw-r--r--audio/libsoxr/pkg-descr12
-rw-r--r--audio/libsoxr/pkg-plist18
6 files changed, 131 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8c6e359642ed..aca98eeb9bdb 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -405,6 +405,7 @@
SUBDIR += libsidplayfp
SUBDIR += libsmf
SUBDIR += libsndfile
+ SUBDIR += libsoxr
SUBDIR += libtremor
SUBDIR += libumidi
SUBDIR += libvorbis
diff --git a/audio/libsoxr/Makefile b/audio/libsoxr/Makefile
new file mode 100644
index 000000000000..110ecbe0c616
--- /dev/null
+++ b/audio/libsoxr/Makefile
@@ -0,0 +1,61 @@
+# $FreeBSD$
+
+PORTNAME= libsoxr
+PORTVERSION= 0.1.2.20160529
+CATEGORIES= audio
+MASTER_SITES= LOCAL/riggs/soxr/
+
+MAINTAINER= riggs@FreeBSD.org
+COMMENT= High quality, one-dimensional sample-rate conversion library
+
+LICENSE= LGPL21+ FFTPAK
+LICENSE_COMB= multi
+LICENSE_NAME_FFTPAK= FFTPAK license
+LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
+LICENSE_FILE_FFTPAK= ${FILESDIR}/FFTPAK_license.txt
+LICENSE_PERMS_FFTPAK= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= cmake pathfix pkgconfig tar:bz2
+
+USE_LDCONFIG= yes
+
+PORTDOCS= NEWS README
+
+CMAKE_MAKE_ARGS+= -DWITH_LSR_BINDINGS:BOOL=ON \
+ -DBUILD_SHARED_LIBS:BOOL=ON
+
+OPTIONS_SUB= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES OPENMP
+OPTIONS_DEFINE_amd64= SIMD
+OPTIONS_DEFINE_i386= SIMD
+SIMD_DESC= Use processor-specific SIMD optimisations
+
+OPTIONS_RADIO= SIMD_DFT
+OPTIONS_RADIO_SIMD_DFT= AVFFT PFFFT
+SIMD_DFT_DESC= Choice of SIMD DFT library
+
+OPENMP_CMAKE_ON= -DWITH_OPENMP:BOOL=ON
+OPENMP_CMAKE_OFF= -DWITH_OPENMP:BOOL=OFF
+OPENMP_USES= compiler:openmp
+
+SIMD_CMAKE_OFF= -DWITH_CR32S:BOOL=OFF \
+ -DWITH_CR64S:BOOL=OFF
+
+AVFFT_DESC= Use external libavcodec
+PFFFT_DESC= Use internal PFFFT
+AVFFT_CMAKE_ON= -DWITH_AVFFT:BOOL=ON
+AVFFT_CMAKE_OFF= -DWITH_AVFFT:BOOL=OFF
+AVFFT_IMPLIES= SIMD
+AVFFT_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
+PFFFT_CMAKE_ON= -DWITH_PFFFT:BOOL=ON
+PFFFT_CMAKE_OFF= -DWITH_PFFFT:BOOL=OFF
+PFFFT_IMPLIES= SIMD
+
+post-patch:
+ @${GREP} -El 'SOURCE_DIR}/LICENCE|AVCODEC_INCLUDE_DIRS' \
+ ${WRKSRC}/CMakeLists.txt | ${XARGS} ${REINPLACE_CMD} \
+ -e '/$${CMAKE_CURRENT_SOURCE_DIR}\/LICENCE/d' \
+ -e 's/AVCODEC_INCLUDE_DIRS/AVCODEC_INCLUDES/'
+
+.include <bsd.port.mk>
diff --git a/audio/libsoxr/distinfo b/audio/libsoxr/distinfo
new file mode 100644
index 000000000000..6b69aeae3c6e
--- /dev/null
+++ b/audio/libsoxr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1466866181
+SHA256 (libsoxr-0.1.2.20160529.tar.bz2) = e9c672ed2707825648eabc099990e4f40226e6c4dfe79bb8904caac57a7d1529
+SIZE (libsoxr-0.1.2.20160529.tar.bz2) = 122474
diff --git a/audio/libsoxr/files/FFTPAK_license.txt b/audio/libsoxr/files/FFTPAK_license.txt
new file mode 100644
index 000000000000..88cc7a0b4091
--- /dev/null
+++ b/audio/libsoxr/files/FFTPAK_license.txt
@@ -0,0 +1,36 @@
+ FFTPACK license:
+
+ http://www.cisl.ucar.edu/css/software/fftpack5/ftpk.html
+
+ Copyright (c) 2004 the University Corporation for Atmospheric
+ Research ("UCAR"). All rights reserved. Developed by NCAR's
+ Computational and Information Systems Laboratory, UCAR,
+ www.cisl.ucar.edu.
+
+ Redistribution and use of the Software in source and binary forms,
+ with or without modification, is permitted provided that the
+ following conditions are met:
+
+ - Neither the names of NCAR's Computational and Information Systems
+ Laboratory, the University Corporation for Atmospheric Research,
+ nor the names of its sponsors or contributors may be used to
+ endorse or promote products derived from this Software without
+ specific prior written permission.
+
+ - Redistributions of source code must retain the above copyright
+ notices, this list of conditions, and the disclaimer below.
+
+ - Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions, and the disclaimer below in the
+ documentation and/or other materials provided with the
+ distribution.
+
+ THIS SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ NONINFRINGEMENT. IN NO EVENT SHALL THE CONTRIBUTORS OR COPYRIGHT
+ HOLDERS BE LIABLE FOR ANY CLAIM, INDIRECT, INCIDENTAL, SPECIAL,
+ EXEMPLARY, OR CONSEQUENTIAL DAMAGES OR OTHER LIABILITY, WHETHER IN AN
+ ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS WITH THE
+ SOFTWARE.
diff --git a/audio/libsoxr/pkg-descr b/audio/libsoxr/pkg-descr
new file mode 100644
index 000000000000..ee9b32c5aa42
--- /dev/null
+++ b/audio/libsoxr/pkg-descr
@@ -0,0 +1,12 @@
+The SoX Resampler library `libsoxr'
+
+It performs one-dimensional sample-rate conversion,
+may be used, for example, to resample PCM-encoded audio.
+
+This library aims to give fast and high quality results for any constant
+(rational or irrational) resampling ratio. Phase-response, preserved
+bandwidth, aliasing, and rejection level parameters are all configurable;
+alternatively, simple `preset' configurations may be selected. An
+experimental, variable-rate resampling mode of operation is also included.
+
+WWW: http://sourceforge.net/p/soxr/
diff --git a/audio/libsoxr/pkg-plist b/audio/libsoxr/pkg-plist
new file mode 100644
index 000000000000..b4e028a01641
--- /dev/null
+++ b/audio/libsoxr/pkg-plist
@@ -0,0 +1,18 @@
+include/soxr-lsr.h
+include/soxr.h
+lib/libsoxr-lsr.so
+lib/libsoxr-lsr.so.0
+lib/libsoxr-lsr.so.0.1.9
+lib/libsoxr.so
+lib/libsoxr.so.0
+lib/libsoxr.so.0.1.2
+libdata/pkgconfig/soxr-lsr.pc
+libdata/pkgconfig/soxr.pc
+%%EXAMPLES%%%%DOCSDIR%%/examples/1-single-block.c
+%%EXAMPLES%%%%DOCSDIR%%/examples/1a-lsr.c
+%%EXAMPLES%%%%DOCSDIR%%/examples/2-stream.C
+%%EXAMPLES%%%%DOCSDIR%%/examples/3-options-input-fn.c
+%%EXAMPLES%%%%DOCSDIR%%/examples/4-split-channels.c
+%%EXAMPLES%%%%DOCSDIR%%/examples/5-variable-rate.c
+%%EXAMPLES%%%%DOCSDIR%%/examples/README
+%%EXAMPLES%%%%DOCSDIR%%/examples/examples-common.h