summaryrefslogtreecommitdiff
path: root/audio/py-essentia/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2024-01-28 21:39:53 +0300
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2024-01-28 21:39:53 +0300
commitd179521238ffd98c49a67787a796f335786e233f (patch)
tree462dcda36efee14f5f7c9a0613bae2f787c231a0 /audio/py-essentia/Makefile
parentbd055f87c93c77246200d72e8851f7780c8ed55b (diff)
downloadfreebsd-ports-d179521238ffd98c49a67787a796f335786e233f.zip
audio/py-essentia: fix build with python 3.11
Bundled waf is outdated and doesn't support changes, introduced in python3.11, this leads to packaging issue. Make it pull freshier waf from upstream repository to fix the issue. PR: 276685 PR: 275494 Approved by: yuri (maintainer)
Diffstat (limited to 'audio/py-essentia/Makefile')
-rw-r--r--audio/py-essentia/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/py-essentia/Makefile b/audio/py-essentia/Makefile
index e1077cfbc4c3..736577e4ea62 100644
--- a/audio/py-essentia/Makefile
+++ b/audio/py-essentia/Makefile
@@ -1,7 +1,7 @@
PORTNAME= essentia
DISTVERSIONPREFIX= v
DISTVERSION= 2.1_beta5-859
-PORTREVISION= 2
+PORTREVISION= 3
DISTVERSIONSUFFIX= -gb247091f
CATEGORIES= audio
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,12 +20,18 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+PATCH_SITES= https://raw.githubusercontent.com/MTG/essentia/d02b6c752046802a711530e2bcd5feafca42247d/
+PATCH_FILES= waf
+
USES= eigen:3 pkgconfig python
USE_PYTHON= pytest
USE_GITHUB= yes
GH_ACCOUNT= MTG
+post-extract:
+ @${CP} ${DISTDIR}/waf ${WRKSRC}/
+
do-configure:
@cd ${BUILD_WRKSRC} && ${SETENV} ${BUILD_ENV} ${PYTHON_CMD} waf configure --only-python