summaryrefslogtreecommitdiff
path: root/audio/cmus
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-04-11 08:34:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-04-11 08:34:17 +0000
commit8d27ddb9bd993385ce5d7a9b17e2fe231ec8c69f (patch)
tree82565381028ebd8b5a674bafdecce3a45c5c2e6d /audio/cmus
parent0a59b351f616abe849539bc2afbc8eba4abe8004 (diff)
downloadfreebsd-ports-8d27ddb9bd993385ce5d7a9b17e2fe231ec8c69f.zip
Add a new macro to deal with conflict between ncurses from base and ncurses from ports.
If a ports is linked against ncurses from base or from the ports, it should then add: USE_NCURSES=yes it is also possible to specify the hard dependency on the ports ncurses or one the base one adding the following macros: WITH_NCURSES_PORT=yes or WITH_NCURSES_BASE=yes PR: ports/155269 Submitted by: me Reviwed by: pav@ Approved by: portmgr (pav@) Exp-run by: portmgr (pav@)
Diffstat (limited to 'audio/cmus')
-rw-r--r--audio/cmus/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index 2c297e89b184..3900e393a988 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -18,6 +18,7 @@ COMMENT= Console-based music player with really cool features
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
+USE_NCURSES= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS+=prefix=${PREFIX} mandir=${MANPREFIX}/man \
exampledir=${EXAMPLESDIR} \
@@ -40,10 +41,6 @@ OPTIONS= FLAC "FLAC (Free Lossless Audio Codec) support" Off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
-LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
-.endif
-
.if defined(WITH_FLAC)
LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
CONFIGURE_ARGS+=CONFIG_FLAC=y