summaryrefslogtreecommitdiff
path: root/audio/acoustid-fingerprinter
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2012-10-27 16:01:04 +0000
committerJason E. Hale <jhale@FreeBSD.org>2012-10-27 16:01:04 +0000
commitad205895ee0c77f337efe363d1a74c4206c341f5 (patch)
treebd68f22481f5a7a3cb4a8edbdc20e7c54ae4e6ac /audio/acoustid-fingerprinter
parentaaab263f360a2acc677117ed0bf83301ff260a2a (diff)
downloadfreebsd-ports-ad205895ee0c77f337efe363d1a74c4206c341f5.zip
AcoustID fingerprinter is a cross-platform GUI application that
uses Chromaprint to submit audio fingerprints from your music collection to the AcoustID database. Only tagged audio files are submitted. Files tagged by MusicBrainz applications such as Picard or Jaikoz are preferred, but it will submit fingerprints for any files that have tags such as track title, artist name, album name, etc. WWW: http://acoustid.org/fingerprinter Approved by: makc, avilla (mentors, implicit) Feature safe: yes
Diffstat (limited to 'audio/acoustid-fingerprinter')
-rw-r--r--audio/acoustid-fingerprinter/Makefile35
-rw-r--r--audio/acoustid-fingerprinter/distinfo2
-rw-r--r--audio/acoustid-fingerprinter/pkg-descr9
-rw-r--r--audio/acoustid-fingerprinter/pkg-plist26
4 files changed, 72 insertions, 0 deletions
diff --git a/audio/acoustid-fingerprinter/Makefile b/audio/acoustid-fingerprinter/Makefile
new file mode 100644
index 000000000000..6919c1897527
--- /dev/null
+++ b/audio/acoustid-fingerprinter/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= acoustid-fingerprinter
+PORTVERSION= 0.6
+CATEGORIES= audio
+MASTER_SITES= http://cloud.github.com/downloads/lalinsky/${PORTNAME}/
+
+MAINTAINER= jhale@FreeBSD.org
+COMMENT= AcoustID audio fingerprint submission tool
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= chromaprint:${PORTSDIR}/audio/chromaprint \
+ tag:${PORTSDIR}/audio/taglib \
+ avcodec:${PORTSDIR}/multimedia/ffmpeg
+
+USE_CMAKE= yes
+USE_QT4= gui network \
+ qmake_build moc_build rcc_build uic_build
+INSTALLS_ICONS= yes
+MAKE_JOBS_SAFE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/cmake/modules/*.cmake
+
+post-install:
+.for i in 16 24 32 48 128 256
+ @${MKDIR} ${PREFIX}/share/icons/hicolor/${i}x${i}/apps
+ ${INSTALL_DATA} ${WRKSRC}/images/acoustid-fp-${i}.png ${PREFIX}/share/icons/hicolor/${i}x${i}/apps/acoustid-fingerprinter.png
+.endfor
+ @${MKDIR} ${PREFIX}/share/icons/hicolor/scalable/apps
+ ${INSTALL_DATA} ${WRKSRC}/images/acoustid-fingerprinter.svg ${PREFIX}/share/icons/hicolor/scalable/apps
+
+.include <bsd.port.mk>
diff --git a/audio/acoustid-fingerprinter/distinfo b/audio/acoustid-fingerprinter/distinfo
new file mode 100644
index 000000000000..864dfde98414
--- /dev/null
+++ b/audio/acoustid-fingerprinter/distinfo
@@ -0,0 +1,2 @@
+SHA256 (acoustid-fingerprinter-0.6.tar.gz) = c0165d4210a181b2baa5e72159bf3f1a9b76398da8794305ddf8e1923ca76f32
+SIZE (acoustid-fingerprinter-0.6.tar.gz) = 93897
diff --git a/audio/acoustid-fingerprinter/pkg-descr b/audio/acoustid-fingerprinter/pkg-descr
new file mode 100644
index 000000000000..062adba0dc85
--- /dev/null
+++ b/audio/acoustid-fingerprinter/pkg-descr
@@ -0,0 +1,9 @@
+AcoustID fingerprinter is a cross-platform GUI application that
+uses Chromaprint to submit audio fingerprints from your music
+collection to the AcoustID database. Only tagged audio files are
+submitted. Files tagged by MusicBrainz applications such as Picard
+or Jaikoz are preferred, but it will submit fingerprints for any
+files that have tags such as track title, artist name, album name,
+etc.
+
+WWW: http://acoustid.org/fingerprinter
diff --git a/audio/acoustid-fingerprinter/pkg-plist b/audio/acoustid-fingerprinter/pkg-plist
new file mode 100644
index 000000000000..273f69d4a230
--- /dev/null
+++ b/audio/acoustid-fingerprinter/pkg-plist
@@ -0,0 +1,26 @@
+bin/acoustid-fingerprinter
+share/applications/acoustid-fingerprinter.desktop
+share/icons/hicolor/128x128/apps/acoustid-fingerprinter.png
+share/icons/hicolor/16x16/apps/acoustid-fingerprinter.png
+share/icons/hicolor/24x24/apps/acoustid-fingerprinter.png
+share/icons/hicolor/256x256/apps/acoustid-fingerprinter.png
+share/icons/hicolor/32x32/apps/acoustid-fingerprinter.png
+share/icons/hicolor/48x48/apps/acoustid-fingerprinter.png
+share/icons/hicolor/scalable/apps/acoustid-fingerprinter.svg
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/256x256/apps
+@dirrmtry share/icons/hicolor/256x256
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications