summaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-01-21 17:40:15 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-01-21 17:40:15 +0000
commitc59a3834c4bd220def36c5006080d4e0f57b83e0 (patch)
treed65d5bf921ef2499700b90c4dc6855a0137ddaf2 /astro
parent556296fe6692c3141d20c3bf87b479397ff4f4b0 (diff)
downloadfreebsd-ports-c59a3834c4bd220def36c5006080d4e0f57b83e0.zip
At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450
ports use BUILD_DEPENDS:= ${RUN_DEPENDS}. This patch fixes ports that are currently broken. This is a temporary measure until we organically stop using := or someone(s) spend a lot of time changing all the ports over. Explicit duplication > := > = and this just moves ports one step to the left Approved by: portmgr
Diffstat (limited to 'astro')
-rw-r--r--astro/p5-Astro-Catalog/Makefile2
-rw-r--r--astro/p5-Astro-SunTime/Makefile2
-rw-r--r--astro/py-RO/Makefile2
-rw-r--r--astro/py-aipy/Makefile2
-rw-r--r--astro/py-pyfits/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/astro/p5-Astro-Catalog/Makefile b/astro/p5-Astro-Catalog/Makefile
index 954aca653bc8..73355eaa905c 100644
--- a/astro/p5-Astro-Catalog/Makefile
+++ b/astro/p5-Astro-Catalog/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= A generic stellar catalogue object
BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/astro/p5-Astro-SunTime/Makefile b/astro/p5-Astro-SunTime/Makefile
index e7a1ff09157f..36680d046669 100644
--- a/astro/p5-Astro-SunTime/Makefile
+++ b/astro/p5-Astro-SunTime/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to calculate sunrise/sunset times
BUILD_DEPENDS= ${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_JOBS_SAFE= yes
diff --git a/astro/py-RO/Makefile b/astro/py-RO/Makefile
index ce115db979cd..6c66055141fc 100644
--- a/astro/py-RO/Makefile
+++ b/astro/py-RO/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= wen@FreeBSD.org
COMMENT= Package of Python astronomical utilities
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:${PORTSDIR}/math/py-numpy
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS= MATPLOTLIB "Add support for Matplotlib" Off \
PYFITS "Add Support for PyFITS" On \
diff --git a/astro/py-aipy/Makefile b/astro/py-aipy/Makefile
index 9edff6a5e91c..9fd5de4d0c46 100644
--- a/astro/py-aipy/Makefile
+++ b/astro/py-aipy/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_SITELIBDIR}/ephem/__init__.py:${PORTSDIR}/astro/pyephem \
${PKGNAMEPREFIX}pyfits>=1.1:${PORTSDIR}/astro/py-pyfits \
${PKGNAMEPREFIX}matplotlib>=0.98:${PORTSDIR}/math/py-matplotlib
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/astro/py-pyfits/Makefile b/astro/py-pyfits/Makefile
index 6de0b25d9e03..b8b4d85efa00 100644
--- a/astro/py-pyfits/Makefile
+++ b/astro/py-pyfits/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= tonymaher@optusnet.com.au
COMMENT= Python Interface to FITS Formatted Files
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:${PORTSDIR}/math/py-numpy
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes