summaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2011-12-12 21:48:08 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2011-12-12 21:48:08 +0000
commitb821b2526d6bc6a21ec83d4ec913ffdbc4a178a3 (patch)
treef126765d14adf587688f5a3f113683da86ce19d7 /astro
parent1ba10dd739219e7c852d7a25001f0791ddb46579 (diff)
downloadfreebsd-ports-b821b2526d6bc6a21ec83d4ec913ffdbc4a178a3.zip
Fix make readme
PR: ports/163159 Submitted by: Jason Helfman <jhelfman@e-e.com>
Diffstat (limited to 'astro')
-rw-r--r--astro/xephem/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/astro/xephem/Makefile b/astro/xephem/Makefile
index 894da9fe7db8..f036ebe23ad8 100644
--- a/astro/xephem/Makefile
+++ b/astro/xephem/Makefile
@@ -33,15 +33,18 @@ XEPHEMSRC= ${PORTNAME}-${PORTVERSION}.tar.gz
.include <bsd.port.pre.mk>
.for file in ${XEPHEMSRC}
-.if !exists(${DISTDIR}/${file}) && !defined(PACKAGE_BUILDING)
-ECHO_MSG= ${PRINTF}
-IGNORE=:\n\
-Because of licensing restrictions, you must manually fetch\n\
-${file} from http://www.clearskyinstitute.com/xephem/,\n\
-place it in ${DISTDIR} and then run make again.\n
+.if !exists(${DISTDIR}/${file}) && !defined(PACKAGE_BUILDING)#{
+DISTFILE_INSTRUCTIONS=\n\
+Because of licensing restrictions, you must manually fetch \n\ ${file} from http://www.clearskyinstitute.com/xephem/, \n\ place it in ${DISTDIR} and then run make again.\n\n
.endif
.endfor
+pre-fetch:
+.if defined(DISTFILE_INSTRUCTIONS)
+ @${PRINTF} "${DISTFILE_INSTRUCTIONS}"
+ @exit 1
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
-e 's|/usr/X11R6|${X11BASE}|g' \