summaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2006-07-28 23:06:19 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2006-07-28 23:06:19 +0000
commit763dbcbad389c4208ea5190c5784421ec7ade6b4 (patch)
tree06a062e27ed4f2ef85af5bb5bb969cb18840ba75 /astro
parentd4040ceb9737bf53352d5448f9014839c92ce2b8 (diff)
downloadfreebsd-ports-763dbcbad389c4208ea5190c5784421ec7ade6b4.zip
Replace ENV with SETENV as it's not defined in bsd.port.mk.
This should fix the "/home/foo/.shrc: Permission denied" error. Reported by: John E Hein <jhein@timing.com>
Diffstat (limited to 'astro')
-rw-r--r--astro/google-earth/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index c1267522448c..19c2495024be 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -60,7 +60,7 @@ do-build:
@${REINPLACE_CMD} -i "" -e 's/^TMPPATH.*/exit 0/' ${WRKSRC}/postinstall.sh
@${REINPLACE_CMD} -i "" -e 's|\"\$$SETUP_INSTALLPATH/|\"${WRKSRC}/|' ${WRKSRC}/postinstall.sh
@${REINPLACE_CMD} -i "" -e 's|\$$SETUP_INSTALLPATH/googleearth |${PREFIX}/bin/googleearth |' ${WRKSRC}/postinstall.sh
- @${ENV} SETUP_INSTALLPATH=${DATADIR} ${WRKSRC}/postinstall.sh
+ @${SETENV} SETUP_INSTALLPATH=${DATADIR} ${WRKSRC}/postinstall.sh
@cd ${WRKSRC} && ${RM} -rf setup.* preuninstall.sh postinstall.sh
@${CHOWN} -R ${SHAREDOWN}:${SHAREDGRP} ${WRKSRC}