summaryrefslogtreecommitdiff
path: root/astro/stellarium/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-06-21 17:15:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-06-21 17:15:59 +0000
commitbddba24f5272e74b0af3d53dfda3a5a614ef8844 (patch)
treeeea1a2c524e8da2c5652fd79e7da51d3a47baabf /astro/stellarium/Makefile
parentf6a9ca67c65cd6ee0e1a9503617d0359c7c2e08f (diff)
downloadfreebsd-ports-bddba24f5272e74b0af3d53dfda3a5a614ef8844.zip
- Update to version 0.10.5
- Consistensify LIB_DEPENDS entries - Augment DESKTOP_ENTRIES (add appropriate categories) - Sort some knobs and cleanup Makefile Feature safe: yes
Diffstat (limited to 'astro/stellarium/Makefile')
-rw-r--r--astro/stellarium/Makefile33
1 files changed, 14 insertions, 19 deletions
diff --git a/astro/stellarium/Makefile b/astro/stellarium/Makefile
index 76401a0aa8ab..a86b2a02fbdf 100644
--- a/astro/stellarium/Makefile
+++ b/astro/stellarium/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= stellarium
-PORTVERSION= 0.10.3
-PORTREVISION= 3
+PORTVERSION= 0.10.5
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Stellarium-sources/${PORTVERSION}
@@ -17,43 +16,39 @@ COMMENT= A 3D photo-realistic sky renderer
LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2
+ freetype.9:${PORTSDIR}/print/freetype2
-USE_QT_VER= 4
-QT_COMPONENTS= moc_build rcc_build uic_build qmake_build \
- corelib gui opengl script network svg qtestlib sql
-USE_GETTEXT= yes
-USE_ICONV= yes
-USE_GL= gl glu
USE_CMAKE= yes
CMAKE_ARGS+= -DFreeType2_INCLUDE_DIR="${LOCALBASE}/include/freetype2" \
-DCMAKE_EXE_LINKER_FLAGS="-L${LOCALBASE}/lib"
-
-PORTDOCS= AUTHORS ChangeLog README
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build rcc_build uic_build qmake_build \
+ corelib gui opengl script network svg qtestlib sql
MAN1= stellarium.1
+PORTDOCS= AUTHORS ChangeLog README
DESKTOP_ENTRIES="Stellarium" \
"View the sky" \
"${DATADIR}/data/stellarium.ico" \
"stellarium" \
- "" \
+ "Application;Astronomy;Education;Science;" \
false
post-patch:
-# _assert conflicts with some macros on 6.x
+# `_assert' conflicts with some macros on FreeBSD 6.x
@${REINPLACE_CMD} -e 's|_assert|_&_|' ${WRKSRC}/src/tests/*.cpp
@${REINPLACE_CMD} -e '/typedef.*void.*__GLXextFuncPtr/ d' \
- ${WRKSRC}/src/external/GLee.h
- @${REINPLACE_CMD} -e '/SET(CMAKE_BUILD_TYPE/ d' \
- ${WRKSRC}/CMakeLists.txt
+ ${WRKSRC}/src/core/external/GLee.h
@${REINPLACE_CMD} -e 's|share/man/man1|man/man1|' \
${WRKSRC}/doc/CMakeLists.txt
-# avoid picking up the wrong fixx11h.h (x11/kdelibs3 installs one that
+# avoid picking up the wrong `fixx11h.h' (x11/kdelibs3 port installs one that
# doesn't handle FontChange)
@${FIND} ${WRKSRC}/src ${WRKSRC}/plugins -type f -print0 | \
- ${XARGS} -0 ${REINPLACE_CMD} -i '' -e 's/fixx11h.h/fixx11qt4h.h/'
- @${MV} ${WRKSRC}/src/external/fixx11h.h ${WRKSRC}/src/external/fixx11qt4h.h
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's/fixx11h\.h/fixx11qt4h.h/'
+ @cd ${WRKSRC}/src/core/external && ${MV} fixx11h.h fixx11qt4h.h
post-install:
.if !defined(NOPORTDOCS)