summaryrefslogtreecommitdiff
path: root/astro/stellarium/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-12-15 14:21:17 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-12-15 14:21:17 +0000
commita33ab20ae82f61a39e3251b481f804aefaaad313 (patch)
tree46d5220b06786c945f9d7bd3215f181eba7c8c2e /astro/stellarium/Makefile
parent79d5253338ef840f5911e619b91328560916b949 (diff)
downloadfreebsd-ports-a33ab20ae82f61a39e3251b481f804aefaaad313.zip
- Update to version 0.10.6
- Mark as MAKE_JOBS_SAFE - Remove explicit LIB_DEPENDS and extra Qt components - Add LICENSE (GPLv2) - Reformat DESKTOP_ENTRIES so they take less space
Diffstat (limited to 'astro/stellarium/Makefile')
-rw-r--r--astro/stellarium/Makefile26
1 files changed, 9 insertions, 17 deletions
diff --git a/astro/stellarium/Makefile b/astro/stellarium/Makefile
index a86b2a02fbdf..d7eb3b0b3be5 100644
--- a/astro/stellarium/Makefile
+++ b/astro/stellarium/Makefile
@@ -6,42 +6,34 @@
#
PORTNAME= stellarium
-PORTVERSION= 0.10.5
+PORTVERSION= 0.10.6
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Stellarium-sources/${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
COMMENT= A 3D photo-realistic sky renderer
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
- freetype.9:${PORTSDIR}/print/freetype2
+LICENSE= GPLv2
USE_CMAKE= yes
-CMAKE_ARGS+= -DFreeType2_INCLUDE_DIR="${LOCALBASE}/include/freetype2" \
- -DCMAKE_EXE_LINKER_FLAGS="-L${LOCALBASE}/lib"
USE_GETTEXT= yes
USE_ICONV= yes
USE_QT_VER= 4
QT_COMPONENTS= moc_build rcc_build uic_build qmake_build \
- corelib gui opengl script network svg qtestlib sql
+ corelib gui network opengl script
+MAKE_JOBS_SAFE= yes
MAN1= stellarium.1
PORTDOCS= AUTHORS ChangeLog README
-DESKTOP_ENTRIES="Stellarium" \
- "View the sky" \
- "${DATADIR}/data/stellarium.ico" \
- "stellarium" \
- "Application;Astronomy;Education;Science;" \
- false
+DESKTOP_ENTRIES="Stellarium" "View the sky" \
+ "${DATADIR}/data/stellarium.ico" "${PORTNAME}" \
+ "Application;Astronomy;Education;Science;" ${FALSE}
post-patch:
-# `_assert' conflicts with some macros on FreeBSD 6.x
- @${REINPLACE_CMD} -e 's|_assert|_&_|' ${WRKSRC}/src/tests/*.cpp
- @${REINPLACE_CMD} -e '/typedef.*void.*__GLXextFuncPtr/ d' \
+ @${REINPLACE_CMD} -e '/typedef.*void.*__GLXextFuncPtr/d' \
${WRKSRC}/src/core/external/GLee.h
+ @${REINPLACE_CMD} -e '/QTTEST/d' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's|share/man/man1|man/man1|' \
${WRKSRC}/doc/CMakeLists.txt
# avoid picking up the wrong `fixx11h.h' (x11/kdelibs3 port installs one that