summaryrefslogtreecommitdiff
path: root/astro/josm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-11-27 23:03:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-11-27 23:03:11 +0000
commitf98e2345f15bea588e1f16da0d0d57ee05b40188 (patch)
tree7ea218e86e5e11c6e1a7f7646801e707aa9fd289 /astro/josm
parent63547acb0319a980c2c23d331318ea3b4f465e34 (diff)
downloadfreebsd-ports-f98e2345f15bea588e1f16da0d0d57ee05b40188.zip
- Update to 4550
- Allow to change memory limit Feature safe: yes
Diffstat (limited to 'astro/josm')
-rw-r--r--astro/josm/Makefile10
-rw-r--r--astro/josm/distinfo4
-rw-r--r--astro/josm/files/josm.sh.in2
3 files changed, 11 insertions, 5 deletions
diff --git a/astro/josm/Makefile b/astro/josm/Makefile
index d2687561c996..8a0985f11ca7 100644
--- a/astro/josm/Makefile
+++ b/astro/josm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= josm
-PORTVERSION= 4487
+PORTVERSION= 4550
CATEGORIES= astro java
MASTER_SITES= http://josm.openstreetmap.de/download/:josm \
http://mirror.amdmi3.ru/distfiles/:josm \
@@ -23,8 +23,10 @@ NO_WRKSUBDIR= yes
USE_JAVA= YES
JAVA_VERSION= 1.5+
+JOSM_MEMORY_LIMIT?=1024
+
SUB_FILES= josm.sh
-SUB_LIST= JARNAME=${DISTNAME}
+SUB_LIST= JARNAME=${DISTNAME} JOSM_MEMORY_LIMIT=${JOSM_MEMORY_LIMIT}
WEBKITIMG= webkit-image
WEBKITIMG_SRC= ${WEBKITIMG}.cpp
@@ -35,6 +37,10 @@ OPTIONS= WEBKIT_IMAGE "Build webkit-image (needed for Yahoo imagery)" off
.include <bsd.port.options.mk>
+pre-everything::
+ @${ECHO_CMD} "You can change limit of memory available to josm by defining"
+ @${ECHO_CMD} "JOSM_MEMORY_LIMIT variable in /etc/make.conf. Default is 1024 (MB)."
+
.if defined(WITH_WEBKIT_IMAGE)
PLIST_FILES+= bin/webkit-image
diff --git a/astro/josm/distinfo b/astro/josm/distinfo
index 6a920cb79f27..03d0f5433ee3 100644
--- a/astro/josm/distinfo
+++ b/astro/josm/distinfo
@@ -1,4 +1,4 @@
-SHA256 (josm-snapshot-4487.jar) = e9a643593cbf37c0ef9a7e42f9d2c34623fda40f47231ffddcaf6e3345a49a28
-SIZE (josm-snapshot-4487.jar) = 6632141
+SHA256 (josm-snapshot-4550.jar) = 0b2e835f26a4b367322e3a873b8c3c0c7515f06a739eb592ea57951520dd309e
+SIZE (josm-snapshot-4550.jar) = 6710648
SHA256 (webkit-image.cpp) = 431f5b956c0e3d1615289dd6cb64effb988b30ace7c80f5a51f9546aa80d300d
SIZE (webkit-image.cpp) = 2718
diff --git a/astro/josm/files/josm.sh.in b/astro/josm/files/josm.sh.in
index 5380e161581c..bfd060df9665 100644
--- a/astro/josm/files/josm.sh.in
+++ b/astro/josm/files/josm.sh.in
@@ -6,4 +6,4 @@ JAVA="%%LOCALBASE%%/bin/java"
JARPATH="%%JAVALIBDIR%%"
export JAVA_VERSION="%%JAVA_VERSION%%"
-exec "${JAVA}" -Xmx1024m -jar "${JARPATH}/%%JARNAME%%" "$@"
+exec "${JAVA}" -Xmx%%JOSM_MEMORY_LIMIT%%m -jar "${JARPATH}/%%JARNAME%%" "$@"