summaryrefslogtreecommitdiff
path: root/astro/google-earth
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2006-07-10 15:02:07 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2006-07-10 15:02:07 +0000
commitee0811b45b4c9a6d848d048b4a323930135e6432 (patch)
tree48d8ffad9fc984738a310c62abe6381c7a4c7bc5 /astro/google-earth
parentad7bd3136e45daab63c7ac1ffaedf2b9813158ed (diff)
downloadfreebsd-ports-ee0811b45b4c9a6d848d048b4a323930135e6432.zip
Add a hack to support lack of versioning in Google tarball names.
Fix plist.
Diffstat (limited to 'astro/google-earth')
-rw-r--r--astro/google-earth/Makefile12
-rw-r--r--astro/google-earth/distinfo6
-rw-r--r--astro/google-earth/pkg-plist4
3 files changed, 17 insertions, 5 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index 7204c2efafda..4ba88654dbbb 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -9,7 +9,7 @@ PORTNAME= google-earth
PORTVERSION= 4.0.1660
CATEGORIES= astro deskutils
MASTER_SITES= http://dl.google.com/earth/GE${PORTVERSION:C/\..*//g}/
-DISTFILES= GoogleEarthLinux.bin
+DISTFILES= ${TARGET_DISTFILE}
EXTRACT_ONLY= # none
MAINTAINER= flz@FreeBSD.org
@@ -25,6 +25,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\..*//g}/
USE_LINUX= yes
USE_GNOME= desktopfileutils
+REAL_DISTFILE= GoogleEarthLinux.bin
+TARGET_DISTFILE= GoogleEarthLinux-${PORTVERSION}.bin
+
+FETCH_CMD= /usr/bin/fetch -ARm
+FETCH_BEFORE_ARGS= -o ${TARGET_DISTFILE}
+
.include <bsd.port.pre.mk>
UNMAKESELF= ${LOCALBASE}/bin/unmakeself
@@ -39,6 +45,10 @@ RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_d
RUN_DEPENDS+= ${LINUXBASE}/lib/libGL.so.1:${PORTSDIR}/graphics/linux_glx
.endif
+do-fetch:
+ @cd ${DISTDIR}; \
+ ${FETCH_CMD} ${FETCH_BEFORE_ARGS} -1 ${MASTER_SITES:S|$|${REAL_DISTFILE}|g} ${FETCH_AFTER_ARGS}
+
do-build:
@${MKDIR} ${WRKSRC}
@${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
diff --git a/astro/google-earth/distinfo b/astro/google-earth/distinfo
index 3f9c70ceff00..e1354021ffee 100644
--- a/astro/google-earth/distinfo
+++ b/astro/google-earth/distinfo
@@ -1,3 +1,3 @@
-MD5 (GoogleEarthLinux.bin) = e61a47c369e596cfa6e75aad058cc657
-SHA256 (GoogleEarthLinux.bin) = 1347a52849b2c245a8200f78cf2aef4fafa45aabc01fb91bbdbfc3baaaf9172e
-SIZE (GoogleEarthLinux.bin) = 17027325
+MD5 (GoogleEarthLinux-4.0.1660.bin) = e61a47c369e596cfa6e75aad058cc657
+SHA256 (GoogleEarthLinux-4.0.1660.bin) = 1347a52849b2c245a8200f78cf2aef4fafa45aabc01fb91bbdbfc3baaaf9172e
+SIZE (GoogleEarthLinux-4.0.1660.bin) = 17027325
diff --git a/astro/google-earth/pkg-plist b/astro/google-earth/pkg-plist
index e87a79afbd32..488dab01f3f0 100644
--- a/astro/google-earth/pkg-plist
+++ b/astro/google-earth/pkg-plist
@@ -608,7 +608,6 @@ share/mime/packages/googleearth-mimetypes.xml
%%DATADIR%%/resources/browser-side.png
%%DATADIR%%/resources/search-dis.png
%%DATADIR%%/resources/american_state_border_fade_out_mask.png
-%%DATADIR%%/resources/collada_building_mask.png
%%DATADIR%%/resources/dc_benchmark_mask.png
%%DATADIR%%/resources/draw_big_placemark_mask.png
%%DATADIR%%/resources/draw_building_mask.png
@@ -646,6 +645,7 @@ share/mime/packages/googleearth-mimetypes.xml
%%DATADIR%%/linux/README-mailto.txt
%%DATADIR%%/lang/qt_it.qm
%%DATADIR%%/lang/es.qm
+%%DATADIR%%/lang/en.qm
%%DATADIR%%/lang/fr.qm
%%DATADIR%%/lang/it.qm
%%DATADIR%%/lang/qt_de.qm
@@ -664,6 +664,7 @@ share/mime/packages/googleearth-mimetypes.xml
%%DATADIR%%/xml/measure.module.xml
%%DATADIR%%/xml/navigate.module.xml
%%DATADIR%%/xml/app.module.xml
+%%DATADIR%%/xml/3dconnexion.plugin.xml
%%DATADIR%%/libtiff.so.3
%%DATADIR%%/libstdc++.so.6
%%DATADIR%%/libssl.so.0.9.8
@@ -707,6 +708,7 @@ share/mime/packages/googleearth-mimetypes.xml
%%DATADIR%%/libIGCore.so
%%DATADIR%%/libIGCollision.so
%%DATADIR%%/libIGAttrs.so
+%%DATADIR%%/lib3dconnexion.so
%%DATADIR%%/googleearth.xpm
%%DATADIR%%/googleearth-icon.png
%%DATADIR%%/googleearth-bin