summaryrefslogtreecommitdiff
path: root/astro/google-earth
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2009-10-19 19:35:15 +0000
committerJuergen Lock <nox@FreeBSD.org>2009-10-19 19:35:15 +0000
commit92a21c7a1afcbfb0d5008975686da7f4a725dafc (patch)
tree273f211bfa528dc67209952bdec3395fe0f14dd8 /astro/google-earth
parenta13461ec99208638b731e051b6105af55bb4cc16 (diff)
downloadfreebsd-ports-92a21c7a1afcbfb0d5008975686da7f4a725dafc.zip
Add a conditional IGNORE so people using a too old Linux base get a
(hopefully) more meaningful error message than a link errror at start. Discussed on: freebsd-emulation@, see this thread: http://lists.freebsd.org/pipermail/freebsd-emulation/2009-October/006970.html
Diffstat (limited to 'astro/google-earth')
-rw-r--r--astro/google-earth/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index aab4e75a9731..fc14ac653ec0 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -38,6 +38,14 @@ RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
USE_LINUX_APPS+= dri
.endif
+.if ${OSVERSION}<700055
+IGNORE= FreeBSD>=7.X is needed with Linux emulation 2.6.x.
+.elif ${OSVERSION}<800076 && \
+ ! defined (OVERRIDE_LINUX_NONBASE_PORTS) || \
+ ! (${OVERRIDE_LINUX_NONBASE_PORTS} == f10)
+IGNORE= needs non-default linux ports (define OVERRIDE_LINUX_BASE_PORT=f10 and OVERRIDE_LINUX_NONBASE_PORTS=f10)
+.endif
+
do-extract:
@${MKDIR} ${WRKSRC}
@${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} ${WRKSRC}