summaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-08-12 05:44:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-08-12 05:44:22 +0000
commitc8cf818032ace38110dad09d664406f9d9ebbe92 (patch)
tree56bf22d0503c92e3974a446963ea97694b97578d /archivers
parent2aab13bac8f6b7316d6bdde2e33469e770a6ba57 (diff)
downloadfreebsd-ports-c8cf818032ace38110dad09d664406f9d9ebbe92.zip
archivers/ccmix: unbreak the build against unsigned-by-default char
On ARM, PowerPC, RISC-V (of the architectures supported by FreeBSD) char type is unsigned by default, which causes the following build error due to incorrect array declaration: mixkey/mix_dexoder.cpp:17:5: error: constant expression evaluates to -1 which cannot be narrowed to type 'char' [-Wc++11-narrowing]
Diffstat (limited to 'archivers')
-rw-r--r--archivers/ccmix/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/archivers/ccmix/Makefile b/archivers/ccmix/Makefile
index b6b43c06115e..cf79627df9af 100644
--- a/archivers/ccmix/Makefile
+++ b/archivers/ccmix/Makefile
@@ -26,6 +26,8 @@ post-patch:
@${REINPLACE_CMD} -e '/ccmix program usage/s,/n,\\n, ; \
/gmd_dir/s,/usr/share/ccmix,${DATADIR},' \
${WRKSRC}/src/ccmix.cpp
+ @${REINPLACE_CMD} -e '/char2num/s,const static,& signed,' \
+ ${WRKSRC}/src/mixkey/mix_dexoder.cpp
do-install:
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/build/* \