summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-12-13 13:24:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-12-13 13:24:16 +0000
commitfaf1a5c0c604f2dc590c05fc0f9c45eb9ff3f048 (patch)
treee48997bc9143ba91defceba62d32bd59033224ea /Mk
parent2a70a3030516754885d5585713c17884b0ca3c5c (diff)
downloadfreebsd-ports-faf1a5c0c604f2dc590c05fc0f9c45eb9ff3f048.zip
Provide a new macro NCURSES_IMPL
This is necessary to deal with the reduction of the ncurses library from 2 implementation on one single implementation which would be only the widechar. Reviewed by: mat Differential Revision: https://reviews.freebsd.org/D22794
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/ncurses.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/Uses/ncurses.mk b/Mk/Uses/ncurses.mk
index f5e42e4baf97..1420722e8465 100644
--- a/Mk/Uses/ncurses.mk
+++ b/Mk/Uses/ncurses.mk
@@ -37,6 +37,9 @@ ncurses_ARGS= port
.if ${ncurses_ARGS} == base
NCURSESBASE= /usr
NCURSESINC= ${NCURSESBASE}/include
+.if !exists(/usr/lib/libncursesw.so)
+NCURSES_IMPL= ncurses
+.endif
. if exists(${LOCALBASE}/lib/libncurses.so)
_USES_sanity+= 400:check-depends-ncurses
@@ -85,5 +88,6 @@ LDFLAGS+= -Wl,-rpath=${NCURSESRPATH}
.endif
NCURSESLIB= ${NCURSESBASE}/lib
+NCURSES_IMPL?= ncursesw
.endif