summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-10-16 00:01:22 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-10-16 00:01:22 +0000
commitd2fc27366b60f8308544ba614ca96d9350db6704 (patch)
treec61242153bc0204d7757f45b823371f218fdf357 /Mk
parentf024d1abd241f8a5650f7449cad5031bcfc9c7f9 (diff)
downloadfreebsd-ports-d2fc27366b60f8308544ba614ca96d9350db6704.zip
www/firefox: update to 63.0
Changes: https://www.mozilla.org/firefox/63.0/releasenotes/ PR: 229893 Security: 7c3a02b9-3273-4426-a0ba-f90fad2ff72e MFH: 2018Q4 Differential Revision: https://reviews.freebsd.org/D16356
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gecko.mk4
-rw-r--r--Mk/bsd.gecko.mk7
2 files changed, 8 insertions, 3 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index 91beea55a217..36ab1ab2b207 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -22,12 +22,12 @@ _GECKO_VERSION= ${gecko_ARGS:M[0-9][0-9]*}
.if ${gecko_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 60
-_GECKO_VERSIONS= 60 62
+_GECKO_VERSIONS= 60 63
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
60_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox-esr
-62_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
+63_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${PKG_QUERY} %v firefox firefox-esr
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index f68e54694e30..15cdf441a063 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -120,6 +120,11 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/python${PYTHON3_DEFAULT}:lang/python${PYTHON3_D
MOZ_EXPORT+= PYTHON3="${LOCALBASE}/bin/python${PYTHON3_DEFAULT}"
.endif
+.if ${MOZILLA_VER:R:R} >= 63
+BUILD_DEPENDS+= rust-cbindgen>=0.6.2:devel/rust-cbindgen \
+ node:www/node
+.endif
+
MOZILLA_SUFX?= none
MOZSRC?= ${WRKSRC}
PLISTF?= ${WRKDIR}/plist_files
@@ -383,7 +388,7 @@ post-patch-SNDIO-on:
.endif
.if ${PORT_OPTIONS:MRUST} || ${MOZILLA_VER:R:R} >= 54
-BUILD_DEPENDS+= ${RUST_PORT:T}>=1.24:${RUST_PORT}
+BUILD_DEPENDS+= ${RUST_PORT:T}>=1.28:${RUST_PORT}
RUST_PORT?= lang/rust
. if ${MOZILLA_VER:R:R} < 54
MOZ_OPTIONS+= --enable-rust