summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-20 21:24:33 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-20 21:24:33 +0000
commitbc23cc2fb839a01bfa1c07089ea49ae127dffe28 (patch)
tree667496d0a3d5cec5f82a2e60f5e8e189bea0fcbe /Mk
parenta66eae4d0aa4ca2eded53ded667e460078ae7c2f (diff)
downloadfreebsd-ports-bc23cc2fb839a01bfa1c07089ea49ae127dffe28.zip
Mk/Uses/qt.mk: Complain about components with an unknown suffix
Normally, USE_QT complains about unknown components with ===> $PKGNAME cannot be installed: unknown USE_QT component 'foobar'. However this fails if the component has a suffix starting with `_`. For example USE_QT= buildtools_build,core or even a simple USE_QT= buildtools_buld is silently accepted, but they do not do anything. Only components with _build and _run suffixes should be accepted. Amend the regular expression we use for this to be stricter. It is currently over eager. Since we only have two cases to cover here we can spell them out explictly instead. PR: 235898 Approved by: kde (tcberner) Differential Revision: https://reviews.freebsd.org/D19267
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/qt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index 768ed7cad679..9257cf397466 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -466,7 +466,7 @@ xmlpatterns-tool_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/xmlpatterns
_USE_QT_ALL+= ${_USE_QT${_QT_VER}_ONLY}
_USE_QT= ${USE_QT}
# Iterate through components deprived of suffix.
-. for component in ${_USE_QT:O:u:C/_.+//}
+. for component in ${_USE_QT:O:u:C/_(build|run)$//}
# Check that the component is valid.
. if ${_USE_QT_ALL:M${component}} != ""
# Skip meta-components (currently none).