summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2022-11-11 13:02:05 +0300
committerGleb Popov <arrowd@FreeBSD.org>2022-11-20 20:39:27 +0300
commitb55505da219d4fe5ded356cfa94486cd4a6d1b80 (patch)
tree0dd9ccbe9f36348eeac9642554c6ee05b16f0eba /Mk
parente254bdde429a3d700beb9d421dc35f1da0b2077a (diff)
downloadfreebsd-ports-b55505da219d4fe5ded356cfa94486cd4a6d1b80.zip
Uses/cabal.mk: Do not extract any USE_CABAL distfiles in cabal-extract.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cabal.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/Uses/cabal.mk b/Mk/Uses/cabal.mk
index ac2ca56fef53..81c487782f87 100644
--- a/Mk/Uses/cabal.mk
+++ b/Mk/Uses/cabal.mk
@@ -169,7 +169,7 @@ EXTRACT_ONLY+= ${_CABAL_EXTRACT_ONLY}
cabal-extract: check-cabal
. if ${_hackage_is_default} == no
@${ECHO_MSG} "===> Recursing down to make extract"
- @${MAKE} -C ${.CURDIR} extract SKIP_CABAL_EXTRACT=yes
+ @${MAKE} -C ${.CURDIR} extract SKIP_CABAL_EXTRACT=yes USE_CABAL=
${RM} -rf ${CABAL_HOME}
. endif
@${ECHO_MSG} "===> Fetching Cabal package index into ${CABAL_HOME}/.cabal"
@@ -183,7 +183,9 @@ cabal-extract: check-cabal
@cd ${WRKSRC} && ${SETENV} HOME=${CABAL_HOME} ${HPACK_CMD}
. endif
. endif
+# Remove Haskell dependencies that come from GH_TUPLE
@${RM} -r ${WRKSRC}/dist-newstyle
+# Create a cookie for cabal-post-patch
@${TOUCH} ${EXTRACT_COOKIE} ${CABAL_COOKIE}
# Calls cabal build --dry-run on the Haskell package located in ${WRKSRC}