summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-12-04 00:54:38 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-12-04 00:54:38 +0000
commit617c9323cd5c8c955ccb8d00af612a9476df20d6 (patch)
tree3bd7b79092d10a2c5d3b7d8a7c89f908926654a1 /Mk
parent7fecbed879d22dea9fb23c037d52c226d1cd3f50 (diff)
downloadfreebsd-ports-617c9323cd5c8c955ccb8d00af612a9476df20d6.zip
www/firefox: update to 64.0
Changes: https://www.mozilla.org/firefox/64.0/releasenotes/ PR: 233028 Security: d10b49b2-8d02-49e8-afde-0844626317af MFH: 2018Q4 Differential Revision: https://reviews.freebsd.org/D17871
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gecko.mk4
-rw-r--r--Mk/bsd.gecko.mk7
2 files changed, 7 insertions, 4 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index 36ab1ab2b207..8d89b5cdd417 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -22,12 +22,12 @@ _GECKO_VERSION= ${gecko_ARGS:M[0-9][0-9]*}
.if ${gecko_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 60
-_GECKO_VERSIONS= 60 63
+_GECKO_VERSIONS= 60 64
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
60_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox-esr
-63_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
+64_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${PKG_QUERY} %v firefox firefox-esr
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 81d06a81152a..4beb1c2808b0 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -115,6 +115,10 @@ BUILD_DEPENDS+= rust-cbindgen>=0.6.2:devel/rust-cbindgen \
node:www/node
.endif
+.if ${MOZILLA_VER:R:R} < 64
+MOZ_OPTIONS+= --enable-pie
+.endif
+
MOZILLA_SUFX?= none
MOZSRC?= ${WRKSRC}
PLISTF?= ${WRKDIR}/plist_files
@@ -220,8 +224,7 @@ MOZ_OPTIONS+= \
--enable-chrome-format=${MOZ_CHROME} \
--enable-default-toolkit=${MOZ_TOOLKIT} \
--enable-update-channel=${MOZ_CHANNEL} \
- --disable-updater \
- --enable-pie
+ --disable-updater
# others
MOZ_OPTIONS+= --with-system-zlib \
--with-system-bz2