summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-11-10 10:09:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-11-10 10:09:48 +0000
commit35326f1a9714f76f3671b263a47134133258ec1b (patch)
treeec00e643384652d97e7643f40c6342bff01bff0b /Mk
parent532b7359be003bf854d62cb7aaccdee30cc43d18 (diff)
downloadfreebsd-ports-35326f1a9714f76f3671b263a47134133258ec1b.zip
security/openssl-devel was removed, but there is a security/openssl111 now.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Scripts/qa.sh2
-rw-r--r--Mk/Uses/ssl.mk2
-rw-r--r--Mk/bsd.default-versions.mk2
3 files changed, 3 insertions, 3 deletions
diff --git a/Mk/Scripts/qa.sh b/Mk/Scripts/qa.sh
index e6ad01b84b0e..a56fe69f9614 100644
--- a/Mk/Scripts/qa.sh
+++ b/Mk/Scripts/qa.sh
@@ -611,7 +611,7 @@ proxydeps_suggest_uses() {
elif [ ${pkg} = "devel/readline" ]; then
warn "you need USES+=readline"
# ssl
- elif [ ${pkg} = "security/openssl" -o ${pkg} = "security/openssl-devel" \
+ elif [ ${pkg} = "security/openssl" -o ${pkg} = "security/openssl111" \
-o ${pkg} = "security/libressl" -o ${pkg} = "security/libressl-devel" \
]; then
warn "you need USES=ssl"
diff --git a/Mk/Uses/ssl.mk b/Mk/Uses/ssl.mk
index 941467a18de1..4e5d48099d8c 100644
--- a/Mk/Uses/ssl.mk
+++ b/Mk/Uses/ssl.mk
@@ -10,7 +10,7 @@
#
# DEFAULT_VERSIONS+= ssl=<openssl variant>
#
-# Variants being base, openssl, openssl-devel, openssl111, libressl, and libressl-devel.
+# Variants being base, openssl, openssl111, libressl, and libressl-devel.
#
# The Makefile sets these variables:
# OPENSSLBASE - "/usr" or ${LOCALBASE}
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 38197e1d1ea3..0a55c65cdd73 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -88,7 +88,7 @@ PYTHON3_DEFAULT?= 3.6
RUBY_DEFAULT?= 2.4
# Possible values: 4.6, 4.7, 4.8
SAMBA_DEFAULT?= 4.7
-# Possible values: base, openssl, openssl-devel, openssl111, libressl, libressl-devel
+# Possible values: base, openssl, openssl111, libressl, libressl-devel
.if !defined(SSL_DEFAULT)
# If no preference was set, check for an installed base version
# but give an installed port preference over it.