summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof <ports@bsdserwis.com>2022-06-18 01:02:42 -0300
committerDanilo G. Baio <dbaio@FreeBSD.org>2022-06-18 01:05:59 -0300
commitfd5978a407e28d5ef4ae0c8c1bf5f5a755a72eaa (patch)
treebe53e289e15cbc262ce1406fed475a33cd469d77
parent266d2cf8819bddbd1c94876f07381d40245871c2 (diff)
downloadfreebsd-ports-fd5978a407e28d5ef4ae0c8c1bf5f5a755a72eaa.zip
mail/pear-Mail_mimeDecode: Fix runtime with PHP 8
PR: 264665
-rw-r--r--mail/pear-Mail_mimeDecode/Makefile1
-rw-r--r--mail/pear-Mail_mimeDecode/files/patch-Mail_mimeDecode.php11
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/pear-Mail_mimeDecode/Makefile b/mail/pear-Mail_mimeDecode/Makefile
index 6a78c14199f9..e656d76cd925 100644
--- a/mail/pear-Mail_mimeDecode/Makefile
+++ b/mail/pear-Mail_mimeDecode/Makefile
@@ -2,6 +2,7 @@
PORTNAME= Mail_mimeDecode
PORTVERSION= 1.5.6
+PORTREVISION= 1
CATEGORIES= mail www pear
MAINTAINER= dbaio@FreeBSD.org
diff --git a/mail/pear-Mail_mimeDecode/files/patch-Mail_mimeDecode.php b/mail/pear-Mail_mimeDecode/files/patch-Mail_mimeDecode.php
new file mode 100644
index 000000000000..47eee5aa76bb
--- /dev/null
+++ b/mail/pear-Mail_mimeDecode/files/patch-Mail_mimeDecode.php
@@ -0,0 +1,11 @@
+--- Mail/mimeDecode.php.orig 2016-08-29 03:04:25 UTC
++++ Mail/mimeDecode.php
+@@ -834,7 +834,7 @@ class Mail_mimeDecode extends PEAR
+
+ // Replace encoded characters
+
+- $cb = create_function('$matches', ' return chr(hexdec($matches[0]));');
++ $cb = function(array $matches) { return chr(hexdec($matches[0])); };
+
+ $input = preg_replace_callback( '/=([a-f0-9]{2})/i', $cb, $input);
+