summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-11-20 21:32:45 +0000
committerLars Thegler <lth@FreeBSD.org>2005-11-20 21:32:45 +0000
commitf8c9f8dde7f7a3b294982f7fdca118ffa430137c (patch)
treea05fb1bf6db5228a7252e1bb78b1725d83ab5b52
parent01efe17e80153596a5f9a97e8eaf9743ab66ca38 (diff)
downloadfreebsd-ports-f8c9f8dde7f7a3b294982f7fdca118ffa430137c.zip
Add p5-Catalyst-Plugin-Session 0.01, generic Catalyst Session plugin.
PR: ports/89167 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-Session/Makefile36
-rw-r--r--www/p5-Catalyst-Plugin-Session/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Session/pkg-descr14
-rw-r--r--www/p5-Catalyst-Plugin-Session/pkg-plist10
5 files changed, 64 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 242d7f4da557..26e356aee680 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -497,6 +497,7 @@
SUBDIR += p5-Catalyst-Plugin-FormValidator
SUBDIR += p5-Catalyst-Plugin-Pluggable
SUBDIR += p5-Catalyst-Plugin-Prototype
+ SUBDIR += p5-Catalyst-Plugin-Session
SUBDIR += p5-Catalyst-Plugin-Session-FastMmap
SUBDIR += p5-Catalyst-Plugin-Singleton
SUBDIR += p5-Catalyst-Plugin-Static
diff --git a/www/p5-Catalyst-Plugin-Session/Makefile b/www/p5-Catalyst-Plugin-Session/Makefile
new file mode 100644
index 000000000000..3128806c5e7c
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Session
+# Date created: Nov 16, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NU/NUFFIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Generic Catalyst Session plugin
+
+BUILD_DEPENDS= p5-Catalyst>=5.50:${PORTSDIR}/www/p5-Catalyst \
+ p5-Digest>=0:${PORTSDIR}/security/p5-Digest \
+ p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools \
+ p5-File-Temp>=0:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Session.3 \
+ Catalyst::Plugin::Session::State.3 \
+ Catalyst::Plugin::Session::Store.3 \
+ Catalyst::Plugin::Session::Store::Dummy.3 \
+ Catalyst::Plugin::Session::Test::Store.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Session/distinfo b/www/p5-Catalyst-Plugin-Session/distinfo
new file mode 100644
index 000000000000..fefe3cacf451
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Session-0.01.tar.gz) = bb0f97b8e836e2471502bff07d2220a1
+SHA256 (Catalyst-Plugin-Session-0.01.tar.gz) = e64637aa90f651969865f6beddac163e8b65cef5715448a16ae2341b89ba3813
+SIZE (Catalyst-Plugin-Session-0.01.tar.gz) = 11842
diff --git a/www/p5-Catalyst-Plugin-Session/pkg-descr b/www/p5-Catalyst-Plugin-Session/pkg-descr
new file mode 100644
index 000000000000..2f899df0cbd7
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session/pkg-descr
@@ -0,0 +1,14 @@
+The Session plugin is the base of two related parts of functionality
+required for session management in web applications.
+
+The first part, the State, is getting the browser to repeat back a
+session key, so that the web application can identify the client and
+logically string several requests together into a session.
+
+The second part, the Store, deals with the actual storage of information
+about the client. This data is stored so that the it may be revived for
+every request made by the same client.
+
+This plugin links the two pieces together.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session/
diff --git a/www/p5-Catalyst-Plugin-Session/pkg-plist b/www/p5-Catalyst-Plugin-Session/pkg-plist
new file mode 100644
index 000000000000..1e7673b82bc8
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Catalyst/Plugin/Session.pm
+%%SITE_PERL%%/Catalyst/Plugin/Session/State.pm
+%%SITE_PERL%%/Catalyst/Plugin/Session/Store.pm
+%%SITE_PERL%%/Catalyst/Plugin/Session/Store/Dummy.pm
+%%SITE_PERL%%/Catalyst/Plugin/Session/Test/Store.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session/Store 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true