summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-21 17:15:14 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-21 17:15:14 +0000
commitf1c41f730541798b9b9a1f046946121eada80c38 (patch)
treec6f586cd1d4a5465956f93cb704a948b73424bc3
parent5c2e8607b151841268833ddcb33466aa4a8da4e3 (diff)
downloadfreebsd-ports-f1c41f730541798b9b9a1f046946121eada80c38.zip
Add USES=readline to fix configure.
-rw-r--r--audio/mpiosh/Makefile2
-rw-r--r--comms/zssh/Makefile3
-rw-r--r--databases/postgresql90-plperl/Makefile2
-rw-r--r--devel/cgdb/Makefile2
-rw-r--r--devel/clewn/Makefile2
-rw-r--r--devel/devtodo/Makefile1
-rw-r--r--devel/hs-readline/Makefile2
-rw-r--r--games/eif/Makefile2
-rw-r--r--lang/nickle/Makefile2
-rw-r--r--lang/rubinius/Makefile2
-rw-r--r--net-mgmt/scli/Makefile2
-rw-r--r--net-p2p/microdc2/Makefile2
-rw-r--r--net/bird-devel/Makefile2
-rw-r--r--net/coda6_server/Makefile2
-rw-r--r--net/zebra/Makefile1
-rw-r--r--sysutils/apachetop/Makefile1
-rw-r--r--sysutils/pwsafe/Makefile2
17 files changed, 18 insertions, 14 deletions
diff --git a/audio/mpiosh/Makefile b/audio/mpiosh/Makefile
index 668037b3e331..d6077a3d539a 100644
--- a/audio/mpiosh/Makefile
+++ b/audio/mpiosh/Makefile
@@ -11,7 +11,7 @@ DISTNAME= mpio-${PORTVERSION:S|.p|_pre|}
MAINTAINER= ports@FreeBSD.org
COMMENT= Digit@lway MPIO MP3 player tool
-USES= iconv
+USES= iconv readline
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/comms/zssh/Makefile b/comms/zssh/Makefile
index aa2e9b4cb0da..02b100af5ebf 100644
--- a/comms/zssh/Makefile
+++ b/comms/zssh/Makefile
@@ -3,10 +3,8 @@
PORTNAME= zssh
PORTVERSION= 1.5c
-PORTREVISION= 0
CATEGORIES= comms security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.5
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactively transferring files to a remote machine while using ssh
@@ -14,6 +12,7 @@ COMMENT= Interactively transferring files to a remote machine while using ssh
RUN_DEPENDS= lrz:${PORTSDIR}/comms/lrzsz
HAS_CONFIGURE= yes
+USES= readline tar:tgz
PLIST_FILES= bin/zssh bin/ztelnet man/man1/zssh.1.gz man/man1/ztelnet.1.gz
diff --git a/databases/postgresql90-plperl/Makefile b/databases/postgresql90-plperl/Makefile
index cf4299a30c8e..642a66ec131d 100644
--- a/databases/postgresql90-plperl/Makefile
+++ b/databases/postgresql90-plperl/Makefile
@@ -14,7 +14,7 @@ MASTERDIR= ${.CURDIR}/../../databases/postgresql${WANT_PGSQL_VER}-server
WANT_PGSQL_VER?=90
-USES= perl5
+USES= perl5 readline
CONFIGURE_ARGS= --with-perl
BUILD_DIRS= src/backend src/pl/plperl
diff --git a/devel/cgdb/Makefile b/devel/cgdb/Makefile
index a16d3012c5c4..e1963065cdba 100644
--- a/devel/cgdb/Makefile
+++ b/devel/cgdb/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://cgdb.me/files/
MAINTAINER= clsung@FreeBSD.org
COMMENT= Curses-based interface to the GNU Debugger
-USES= makeinfo
+USES= makeinfo readline
INFO= cgdb
diff --git a/devel/clewn/Makefile b/devel/clewn/Makefile
index 53d23e359b0b..f7d55f80bf28 100644
--- a/devel/clewn/Makefile
+++ b/devel/clewn/Makefile
@@ -12,7 +12,7 @@ COMMENT= Clewn provides Gdb support within Vim
RUN_DEPENDS= vim:${PORTSDIR}/editors/vim
-USES= gmake
+USES= gmake readline
GNU_CONFIGURE= yes
CONFIGURE_ENV= vimdir=${PREFIX}/share/vim/vimfiles
diff --git a/devel/devtodo/Makefile b/devel/devtodo/Makefile
index 079a2037e904..e9639aa94262 100644
--- a/devel/devtodo/Makefile
+++ b/devel/devtodo/Makefile
@@ -13,6 +13,7 @@ COMMENT= Tool to effectively maintain todo lists aimed at developers
CONFLICTS= tdl-[0-9]* todo-[0-9]*
GNU_CONFIGURE= yes
+USES= readline
OPTIONS_DEFINE= EXAMPLES
diff --git a/devel/hs-readline/Makefile b/devel/hs-readline/Makefile
index 4c084d310a62..74a0b7e6d690 100644
--- a/devel/hs-readline/Makefile
+++ b/devel/hs-readline/Makefile
@@ -11,5 +11,7 @@ COMMENT= Interface to the GNU readline library
LICENSE= GPLv2
+USES= readline
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/games/eif/Makefile b/games/eif/Makefile
index cd93f157d044..b5a23a5984ef 100644
--- a/games/eif/Makefile
+++ b/games/eif/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= Empire text client
GNU_CONFIGURE= yes
-USES= shebangfix
+USES= shebangfix readline
SHEBANG_FILES= contrib/*.pl
.include <bsd.port.pre.mk>
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index e28cee43acb7..2e7bfdd583c0 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -11,7 +11,7 @@ COMMENT= Numeric-oriented programming language
LICENSE= MIT
-USES= gmake ncurses
+USES= gmake ncurses readline
GNU_CONFIGURE= yes
# Nickle now has bindings which are likely to pull in libraries that need
diff --git a/lang/rubinius/Makefile b/lang/rubinius/Makefile
index b48f4ee6a70a..2a81bcc62f4e 100644
--- a/lang/rubinius/Makefile
+++ b/lang/rubinius/Makefile
@@ -37,7 +37,7 @@ CONFIGURE_ARGS= -P "${PREFIX}" \
--vendordir "${PREFIX}/lib/ruby/vendor_ruby/rubinius" \
--stagingdir "${STAGEDIR}${PREFIX}" --with-execinfo
-USES= perl5 gmake tar:bzip2
+USES= perl5 gmake tar:bzip2 readline
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS= yes
USE_PERL5= build
diff --git a/net-mgmt/scli/Makefile b/net-mgmt/scli/Makefile
index ca8032715fde..6be6169175f7 100644
--- a/net-mgmt/scli/Makefile
+++ b/net-mgmt/scli/Makefile
@@ -14,7 +14,7 @@ COMMENT= A collection of SNMP command line management tools
LIB_DEPENDS= libgsnmp.so:${PORTSDIR}/net-mgmt/gsnmp
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig readline
USE_GNOME= libxml2
INFO= scli
diff --git a/net-p2p/microdc2/Makefile b/net-p2p/microdc2/Makefile
index ba368149543a..bac679ccb775 100644
--- a/net-p2p/microdc2/Makefile
+++ b/net-p2p/microdc2/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
CONFLICTS= tthsum-[0-9]*
-USES= iconv
+USES= iconv readline
GNU_CONFIGURE= yes
USE_GNOME= libxml2
diff --git a/net/bird-devel/Makefile b/net/bird-devel/Makefile
index 24d62b62954a..6586290da0fb 100644
--- a/net/bird-devel/Makefile
+++ b/net/bird-devel/Makefile
@@ -12,7 +12,7 @@ COMMENT= Dynamic IP routing daemon (devel version)
CONFLICTS= bird-[0-9]*
-USES= bison gmake
+USES= bison gmake readline
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --enable-mpls
USE_CSTD= gnu89
diff --git a/net/coda6_server/Makefile b/net/coda6_server/Makefile
index ceae6cefabab..21d4e511caff 100644
--- a/net/coda6_server/Makefile
+++ b/net/coda6_server/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= liblwp.so:${PORTSDIR}/devel/lwp \
librpc2.so:${PORTSDIR}/devel/rpc2 \
librvmlwp.so:${PORTSDIR}/devel/rvm
-USES= pkgconfig gmake shebangfix perl5
+USES= pkgconfig gmake shebangfix perl5 readline
USE_PERL5= run
SHEBANG_FILES= coda-src/scripts/tape.pl \
coda-src/scripts/volinfo.pl \
diff --git a/net/zebra/Makefile b/net/zebra/Makefile
index 24ba06949d1d..3ce6f235db62 100644
--- a/net/zebra/Makefile
+++ b/net/zebra/Makefile
@@ -26,6 +26,7 @@ SUB_LIST= BGPDARGS=${BGPDARGS} \
ZEBRAARGS=${ZEBRAARGS}
USE_SUBMAKE= yes
GNU_CONFIGURE= yes
+USES= readline
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/zebra
PORTSCOUT= ignore:1
diff --git a/sysutils/apachetop/Makefile b/sysutils/apachetop/Makefile
index 5089df749954..837f63e783e7 100644
--- a/sysutils/apachetop/Makefile
+++ b/sysutils/apachetop/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Apache RealTime log stats
GNU_CONFIGURE= yes
+USES= readline
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
diff --git a/sysutils/pwsafe/Makefile b/sysutils/pwsafe/Makefile
index 065eecc993c2..78357c40f42b 100644
--- a/sysutils/pwsafe/Makefile
+++ b/sysutils/pwsafe/Makefile
@@ -13,7 +13,7 @@ COMMENT= Cmdline program that manages encrypted password databases
OPTIONS_DEFINE= SETUID X11
SETUID_DESC= Install setuid pwsafe binary
-USES= gmake
+USES= gmake readline
GNU_CONFIGURE= yes
PLIST_FILES= bin/pwsafe man/man1/pwsafe.1.gz