summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeal Nelson <ports@nicandneal.net>2023-09-07 15:51:32 +0200
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-10 12:13:04 -0400
commitf0da8a9cde456193a4ed5e322eb957632b7f3c3d (patch)
treeb38d195930d793b9207edc374d9be2b7ef2375f4
parent9fd4b3987423a3fb7a0215c821a5764b43ce81a0 (diff)
downloadfreebsd-ports-f0da8a9cde456193a4ed5e322eb957632b7f3c3d.zip
devel/nimble: find lang/nim in its new home
PR: 273482
-rw-r--r--devel/nimble/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/nimble/Makefile b/devel/nimble/Makefile
index c82c985b1911..bf6953e53f52 100644
--- a/devel/nimble/Makefile
+++ b/devel/nimble/Makefile
@@ -10,8 +10,8 @@ WWW= https://github.com/nim-lang/nimble
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/license.txt
-BUILD_DEPENDS= nim:lang/nim
-RUN_DEPENDS= nim:lang/nim
+BUILD_DEPENDS= ${LOCALBASE}/nim/bin/nim:lang/nim
+RUN_DEPENDS= ${LOCALBASE}/nim/bin/nim:lang/nim
USE_GITHUB= yes
GH_ACCOUNT= nim-lang
@@ -19,7 +19,7 @@ GH_ACCOUNT= nim-lang
PLIST_FILES= bin/nimble
do-build:
- @cd ${WRKSRC} && nim c -d:release --noNimblePath --parallelBuild=${MAKE_JOBS_NUMBER} --path:${LOCALBASE}/nim --nimcache:${WRKSRC}/nimcache src/nimble
+ @cd ${WRKSRC} && ${LOCALBASE}/nim/bin/nim c -d:release --noNimblePath --parallelBuild=${MAKE_JOBS_NUMBER} --path:${LOCALBASE}/nim --nimcache:${WRKSRC}/nimcache src/nimble
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/nimble ${STAGEDIR}${PREFIX}/bin