summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2019-06-13 06:20:04 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2019-06-13 06:20:04 +0000
commite66727024b2eeefde866329632e37e71694a8b45 (patch)
tree2cf8ece4472a68f915753a94cb986f768b4db34b
parentfb252b60a7e47d54af739072498909788d827d1f (diff)
downloadfreebsd-ports-e66727024b2eeefde866329632e37e71694a8b45.zip
Recommend the use of GCC 8 (instead of GCC 7 until now) to replace
these older versions of GCC - GCC 4.8, GCC 5, and GCC 6 - which have been end-of-lifed upstream many moons ago. GCC 8 has been the default version of GCC in the Ports Collection for a while and as such proven itself, plus of all versions it is most likely to be present/used. No functional change, just updated advice to our users.
-rw-r--r--lang/gcc48/Makefile2
-rw-r--r--lang/gcc5/Makefile2
-rw-r--r--lang/gcc6/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 52b986ec1e12..cbfde8875e14 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -14,7 +14,7 @@ COMMENT= GNU Compiler Collection 4.8
LICENSE= GPLv3 GPLv3RLE
LICENSE_COMB= multi
-DEPRECATED= Unsupported by upstream. Use GCC 7 or newer instead.
+DEPRECATED= Unsupported by upstream. Use GCC 8 or newer instead.
ONLY_FOR_ARCHS= amd64 armv6 i386 powerpc powerpc64 sparc64
LIB_DEPENDS= libgmp.so:math/gmp \
diff --git a/lang/gcc5/Makefile b/lang/gcc5/Makefile
index c87a85956b59..02340fe9b157 100644
--- a/lang/gcc5/Makefile
+++ b/lang/gcc5/Makefile
@@ -14,7 +14,7 @@ COMMENT= GNU Compiler Collection 5
LICENSE= GPLv3 GPLv3RLE
LICENSE_COMB= multi
-DEPRECATED= Unsupported by upstream. Use GCC 7 or newer instead.
+DEPRECATED= Unsupported by upstream. Use GCC 8 or newer instead.
ONLY_FOR_ARCHS= aarch64 amd64 arm armv6 i386 powerpc powerpc64 powerpcspe sparc64
BROKEN_sparc64= Does not build: bootstrap comparison failure
diff --git a/lang/gcc6/Makefile b/lang/gcc6/Makefile
index 9bb0e39fdb21..ec0828f740e2 100644
--- a/lang/gcc6/Makefile
+++ b/lang/gcc6/Makefile
@@ -14,7 +14,7 @@ COMMENT= GNU Compiler Collection 6
LICENSE= GPLv3 GPLv3RLE
LICENSE_COMB= multi
-DEPRECATED= Unsupported by upstream. Use GCC 7 or newer instead.
+DEPRECATED= Unsupported by upstream. Use GCC 8 or newer instead.
ONLY_FOR_ARCHS= aarch64 amd64 arm armv6 armv7 i386 powerpc powerpc64 powerpcspe sparc64
BROKEN_sparc64= fails to configure: cannot compute suffix of object files: cannot compile