summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-06-19 09:44:21 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-06-19 09:44:21 +0000
commite45d39f39bc16147fae6e57085386ff7b32f559c (patch)
treeadb9892c0e27b5043345860d23638f966a5a9fcc
parentf6f4ea09f1855b56f1053f616f0e5b091505db24 (diff)
downloadfreebsd-ports-e45d39f39bc16147fae6e57085386ff7b32f559c.zip
Fix interface name fetching.
PR: 210380 Submitted by: allanjude Obtained from: OpenBSD ports
-rw-r--r--net/nload/Makefile1
-rw-r--r--net/nload/files/patch-src_devreader-bsd.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/nload/Makefile b/net/nload/Makefile
index 97b6064608c1..95fc9489877b 100644
--- a/net/nload/Makefile
+++ b/net/nload/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nload
PORTVERSION= 0.7.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.roland-riegel.de/nload/ \
LOCAL/ehaupt
diff --git a/net/nload/files/patch-src_devreader-bsd.cpp b/net/nload/files/patch-src_devreader-bsd.cpp
new file mode 100644
index 000000000000..e827ac671ebb
--- /dev/null
+++ b/net/nload/files/patch-src_devreader-bsd.cpp
@@ -0,0 +1,11 @@
+--- src/devreader-bsd.cpp.orig 2011-06-12 10:01:11 UTC
++++ src/devreader-bsd.cpp
+@@ -91,7 +91,7 @@ list<string> DevReaderBsd::findAllDevice
+ if(sdl->sdl_family != AF_LINK)
+ continue;
+
+- interfaceNames.push_back(string(sdl->sdl_data));
++ interfaceNames.push_back(string(sdl->sdl_data, sdl->sdl_nlen));
+ }
+
+ free(buf);