summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-11-13 14:00:50 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-11-13 14:00:50 +0000
commitda704f951a93294c72ece9cb36036d3b3a1be391 (patch)
tree21b2b033704a50fa3396be067d97e0f8b61da063
parent1ba7698def3d7dbbd937f2b76489066ebbf495da (diff)
downloadfreebsd-ports-da704f951a93294c72ece9cb36036d3b3a1be391.zip
graphics/llpp: Fix 'crashes Firefox sometimes'
- This one is related to bug #199872 where Firefox would randomly crash when exiting llpp (sometimes yes and sometimes no, you don't know which beforehand). Firefox (or GTK+ apps in general) seems to monitor ~/.config (not sure if true). llpp writes to ~/.config/llpp.conf when it exits, which will trigger bug #199872. - This patch moves llpp's config file to ~/.llpp.conf instead, solving this annoyance. PR: 214458 Submitted by: Tobias Kortkamp <t@tobik.me> (maintainer)
-rw-r--r--graphics/llpp/Makefile2
-rw-r--r--graphics/llpp/files/patch-config.ml21
2 files changed, 22 insertions, 1 deletions
diff --git a/graphics/llpp/Makefile b/graphics/llpp/Makefile
index 057860e58c47..ac988c3b1654 100644
--- a/graphics/llpp/Makefile
+++ b/graphics/llpp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= llpp
PORTVERSION= 22
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://repo.or.cz/llpp.git/snapshot/
DISTNAME= 561dc5673cea431e930668b0d87b0c4b31a36b39
diff --git a/graphics/llpp/files/patch-config.ml b/graphics/llpp/files/patch-config.ml
new file mode 100644
index 000000000000..43a5c69e154a
--- /dev/null
+++ b/graphics/llpp/files/patch-config.ml
@@ -0,0 +1,21 @@
+--- config.ml.orig 2015-10-13 20:12:27 UTC
++++ config.ml
+@@ -1420,17 +1420,7 @@ let do_load f contents =
+ ;;
+
+ let defconfpath =
+- let dir =
+- let xdgconfdir = Utils.getenvwithdef "XDG_CONFIG_HOME" E.s in
+- if emptystr xdgconfdir
+- then
+- try
+- let dir = Filename.concat home ".config" in
+- if Sys.is_directory dir then dir else home
+- with _ -> home
+- else xdgconfdir
+- in
+- Filename.concat dir "llpp.conf"
++ Filename.concat home ".llpp.conf"
+ ;;
+
+ let confpath = ref defconfpath;;