summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-10-16 23:18:31 +0800
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-10-16 23:59:44 +0800
commitd37f408537cb1670d3e87e05e875dc361c7ba538 (patch)
treebb372f79c8ec82ff8d653973097426b3cd58c8ea
parent5ce890ac985429051c00ca5558a7301ea9e86d89 (diff)
downloadfreebsd-ports-d37f408537cb1670d3e87e05e875dc361c7ba538.zip
astro/py-astlib: Update to 0.11.9
- Convert to USE_PYTHON=pep517 Changes: https://github.com/mattyowl/astLib/releases
-rw-r--r--astro/py-astlib/Makefile7
-rw-r--r--astro/py-astlib/distinfo6
-rw-r--r--astro/py-astlib/files/patch-setup.py23
3 files changed, 30 insertions, 6 deletions
diff --git a/astro/py-astlib/Makefile b/astro/py-astlib/Makefile
index ff5a9717e5e8..6b64531c8b91 100644
--- a/astro/py-astlib/Makefile
+++ b/astro/py-astlib/Makefile
@@ -1,6 +1,5 @@
PORTNAME= astlib
-PORTVERSION= 0.11.8
-PORTREVISION= 1
+PORTVERSION= 0.11.9
CATEGORIES= astro python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,6 +13,8 @@ WWW= https://astlib.readthedocs.io/en/latest/ \
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=1.1:astro/py-astropy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=0.1:math/py-numpy@${PY_FLAVOR} \
@@ -21,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=1.1:astro/py-astropy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
diff --git a/astro/py-astlib/distinfo b/astro/py-astlib/distinfo
index e367ab8c4e9e..d285fb0c48ce 100644
--- a/astro/py-astlib/distinfo
+++ b/astro/py-astlib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1661599215
-SHA256 (astLib-0.11.8.tar.gz) = 2bb3619a71bada2375d5b10ad364a85a0bc631f6580c48537c192b40f70bc5fd
-SIZE (astLib-0.11.8.tar.gz) = 9913587
+TIMESTAMP = 1697463070
+SHA256 (astLib-0.11.9.tar.gz) = b2f9b7be58ffa96fc7876732038694d0faba026a0bf53003ccb0010c0e54feb7
+SIZE (astLib-0.11.9.tar.gz) = 9917509
diff --git a/astro/py-astlib/files/patch-setup.py b/astro/py-astlib/files/patch-setup.py
new file mode 100644
index 000000000000..22b8c234a3fe
--- /dev/null
+++ b/astro/py-astlib/files/patch-setup.py
@@ -0,0 +1,23 @@
+Reference: https://github.com/mattyowl/astLib/pull/9
+ https://github.com/mattyowl/astLib/commit/6844b308fb9ff1a71486dff98793bfec1ed13349
+
+--- setup.py.orig 2023-10-12 15:29:16 UTC
++++ setup.py
+@@ -36,7 +36,7 @@ class build_PyWCSTools_ext(build_ext):
+
+ os.chdir(sourceDir)
+ cc=setuptools._distutils.ccompiler.new_compiler(setuptools._distutils.ccompiler.get_default_compiler())
+- cc.compiler_so=[sysconfig.get_config_var('CC')]+sysconfig.get_config_var('CFLAGS').split()+sysconfig.get_config_var('CFLAGSFORSHARED').split()
++ cc.compiler_so=sysconfig.get_config_var('CC').split()+sysconfig.get_config_var('CFLAGS').split()+sysconfig.get_config_var('CFLAGSFORSHARED').split()
+
+ # Suppress warnings from compiling WCSTools wcssubs-3.9.5
+ if "-Wstrict-prototypes" in cc.compiler_so:
+@@ -55,7 +55,7 @@ class build_PyWCSTools_ext(build_ext):
+
+ build_ext.build_extensions(self)
+
+-setup(name='astLib',
++setup(name='astlib',
+ version='0.11.9',
+ url='https://astlib.readthedocs.io',
+ author='Matt Hilton & Steven Boada',