summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-11-27 19:58:30 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-11-27 19:58:30 +0000
commitca9849cd62928403fb20220380554df3ec8c52df (patch)
tree4cf074d26fa4016cfeb5a353d1133599366ea9bd
parenta67a5042f1afb1f6e395aafcbc56575cba286ad3 (diff)
downloadfreebsd-ports-ca9849cd62928403fb20220380554df3ec8c52df.zip
lang/php7*: disable DTRACE on powerpc64
php ports don't build on elfv2 with DTRACE. PR: 242113, 242114, 242116 Approved by: tz (maintainer), tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D22577 Differential Revision: https://reviews.freebsd.org/D22578 Differential Revision: https://reviews.freebsd.org/D22579
-rw-r--r--lang/php71/Makefile1
-rw-r--r--lang/php72/Makefile1
-rw-r--r--lang/php73/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/lang/php71/Makefile b/lang/php71/Makefile
index e44ca93ad707..58dbb6368e40 100644
--- a/lang/php71/Makefile
+++ b/lang/php71/Makefile
@@ -39,6 +39,7 @@ OPTIONS_DEFAULT=CLI CGI FPM EMBED MYSQLND LINKTHR DTRACE
OPTIONS_EXCLUDE_DragonFly= DTRACE
# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
OPTIONS_EXCLUDE_aarch64= DTRACE
+OPTIONS_EXCLUDE_powerpc64= DTRACE
# dt_modtext:opensolaris/ib/libdtrace/common/dt_link.c: arm not impemented
OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
diff --git a/lang/php72/Makefile b/lang/php72/Makefile
index c7fe53f8cd9f..5240ac371741 100644
--- a/lang/php72/Makefile
+++ b/lang/php72/Makefile
@@ -40,6 +40,7 @@ OPTIONS_DEFAULT=CLI CGI FPM EMBED MYSQLND LINKTHR DTRACE
OPTIONS_EXCLUDE_DragonFly= DTRACE
# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
OPTIONS_EXCLUDE_aarch64= DTRACE
+OPTIONS_EXCLUDE_powerpc64= DTRACE
# dt_modtext:opensolaris/ib/libdtrace/common/dt_link.c: arm not impemented
OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
diff --git a/lang/php73/Makefile b/lang/php73/Makefile
index ecd1732118b8..c4adb3e9a919 100644
--- a/lang/php73/Makefile
+++ b/lang/php73/Makefile
@@ -42,6 +42,7 @@ OPTIONS_EXCLUDE_DragonFly= DTRACE
# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
OPTIONS_EXCLUDE_aarch64= DTRACE
OPTIONS_EXCLUDE_powerpc= DTRACE
+OPTIONS_EXCLUDE_powerpc64= DTRACE
# dt_modtext:opensolaris/ib/libdtrace/common/dt_link.c: arm not impemented
OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE