summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-26 22:51:33 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-26 22:51:33 +0000
commitca7d460ca3542d12422a2919700851e792dd1e44 (patch)
tree2cb5b1fbbc68bf2f3555133687eef8c7b864f1b1
parent0c186dcad598774b9f1eda444fd532fba12e80a7 (diff)
downloadfreebsd-ports-ca7d460ca3542d12422a2919700851e792dd1e44.zip
devel/ocaml-lwt: Upgrade from 1.1.0 -> 2.4.3 and support stage
This is a major update. The PR was followed, but it came pre-stage era. The staging came from pkgsrc where the maintainer maintains the same DESTDIR-enabled package. PR: ports/176061 Submitted by: maintainer (Jaap Boender) Stage support: Taken from pkgsrc
-rw-r--r--devel/ocaml-lwt/Makefile72
-rw-r--r--devel/ocaml-lwt/distinfo4
2 files changed, 57 insertions, 19 deletions
diff --git a/devel/ocaml-lwt/Makefile b/devel/ocaml-lwt/Makefile
index 2851e9a3ecbe..f521cde4f5d1 100644
--- a/devel/ocaml-lwt/Makefile
+++ b/devel/ocaml-lwt/Makefile
@@ -2,39 +2,77 @@
# $FreeBSD$
PORTNAME= lwt
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 2.4.3
CATEGORIES= devel
-MASTER_SITES= http://www.ocsigen.org/download/
+MASTER_SITES= http://ocsigen.org/download/
PKGNAMEPREFIX= ocaml-
MAINTAINER= jaapb@kerguelen.org
COMMENT= Cooperative threading library for OCaml
+LICENSE= LGPL21
+
+BUILD_DEPENDS= ${SA_DIR}/react/react.a:${PORTSDIR}/devel/ocaml-react \
+ ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
+RUN_DEPENDS= ${SA_DIR}/react/react.a:${PORTSDIR}/devel/ocaml-react \
+ ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
+
MAKE_JOBS_UNSAFE= yes
+USES= gmake
USE_OCAML= yes
-OCAMLC_DEPEND= ocaml>=3.10:${OCAMLC_PORT}
+OCAMLC_DEPEND= ocaml>=3.11:${OCAMLC_PORT}
USE_OCAML_FINDLIB= yes
USE_OCAMLFIND_PLIST= yes
-USE_OCAML_LDCONFIG= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --destdir "${STAGEDIR}" \
+ --prefix "${PREFIX}" \
+ --enable-ssl \
+ --enable-react \
+ --disable-libev \
+ --disable-glib
-USE_GMAKE= yes
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
-PORTDOCS= *
+SA_DIR= ${PREFIX}/${OCAML_SITELIBDIR}
-BUILD_DEPENDS+= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
-RUN_DEPENDS+= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
+OPTIONS_DEFINE= TOPLEVEL
+OPTIONS_DEFAULT= TOPLEVEL
+TOPLEVEL_DESC= Include enhanced OCaml toplevel
-SA_DIR= ${PREFIX}/${OCAML_SITELIBDIR}
+.include <bsd.port.options.mk>
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MTOPLEVEL}
+CONFIGURE_ARGS+= --enable-toplevel --enable-text
+BUILD_DEPENDS+= ${SA_DIR}/text/text.a:${PORTSDIR}/textproc/ocaml-text
+RUN_DEPENDS+= ${SA_DIR}/text/text.a:${PORTSDIR}/textproc/ocaml-text
+PLIST_FILES= bin/lwt-toplevel
+.else
+CONFIGURE_ARGS+= --disable-toplevel --disable-text
+.endif
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/_build/lwt.docdir/* ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+CONFIGURE_ARGS+= --enable-docs --docdir ${STAGEDIR}${DOCSDIR}
+# For some reason, ocaml-text is needed when building documentation
+BUILD_DEPENDS+= ${SA_DIR}/text/text.a:${PORTSDIR}/textproc/ocaml-text
+RUN_DEPENDS+= ${SA_DIR}/text/text.a:${PORTSDIR}/textproc/ocaml-text
+.else
+CONFIGURE_ARGS+= --disable-docs
.endif
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's,"install" :: findlib_name,"install" :: "-destdir ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib" :: "-ldconf /dev/null" :: findlib_name,' \
+ ${WRKSRC}/setup.ml
+
+do-configure:
+ (cd ${WRKSRC}; ocaml setup.ml -configure ${CONFIGURE_ARGS})
+ @${REINPLACE_CMD} -e 's%"-lev"%"-lev -L${PREFIX}/lib/ev -Wl,-R${PREFIX}/lib/ev"%' \
+ ${WRKSRC}/setup.data
+
+do-build:
+ (cd ${WRKSRC}; ocaml setup.ml -build)
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${SA_DIR}
+ (cd ${WRKSRC}; ocaml setup.ml -install)
+
+.include <bsd.port.mk>
diff --git a/devel/ocaml-lwt/distinfo b/devel/ocaml-lwt/distinfo
index 637a6e26ad30..56ba3f1140af 100644
--- a/devel/ocaml-lwt/distinfo
+++ b/devel/ocaml-lwt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lwt-1.1.0.tar.gz) = 6c9087e1185de933091fcd147f1c125157b01921d32ca0e2304319c2d72ee9d6
-SIZE (lwt-1.1.0.tar.gz) = 32844
+SHA256 (lwt-2.4.3.tar.gz) = efee23937750290d6dee96eed6c0bbdb19817d5be6eefcba61ac5031fac10107
+SIZE (lwt-2.4.3.tar.gz) = 504000