summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2014-10-15 07:06:31 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2014-10-15 07:06:31 +0000
commitc5eaaa0ecfac655ad5d38c661ca496967f105136 (patch)
tree1ea1be2f167dea81d13e4954cebfd7af2b9cade3
parentd5688c77181ad9139fb873abcbece94da7bb87e4 (diff)
downloadfreebsd-ports-c5eaaa0ecfac655ad5d38c661ca496967f105136.zip
Fix a bug with the location counter calculation that becomes obvious
when running on 64-bit machines. Submitted by: Holm Tiffe <holm@freibergnet.de> Obtained from: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=655487
-rw-r--r--devel/as31/Makefile2
-rw-r--r--devel/as31/files/patch-debianbug65548719
2 files changed, 20 insertions, 1 deletions
diff --git a/devel/as31/Makefile b/devel/as31/Makefile
index 993554e4a23a..2a98d8df4fcb 100644
--- a/devel/as31/Makefile
+++ b/devel/as31/Makefile
@@ -3,7 +3,7 @@
PORTNAME= as31
PORTVERSION= 2.0.b3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel
MASTER_SITES= http://www.pjrc.com/tech/8051/tools/
DISTNAME= ${PORTNAME}_beta3
diff --git a/devel/as31/files/patch-debianbug655487 b/devel/as31/files/patch-debianbug655487
new file mode 100644
index 000000000000..e608455c5546
--- /dev/null
+++ b/devel/as31/files/patch-debianbug655487
@@ -0,0 +1,19 @@
+--- parser.y~ 2014-10-15 09:01:14.265779740 +0200
++++ parser.y 2014-10-15 09:02:26.951775397 +0200
+@@ -1016,13 +1016,13 @@
+ *
+ */
+
+-#define indx(a) ( (a)/(sizeof(long)*8) )
+-#define bit(a) ( 1 << ((a)%(sizeof(long)*8)) )
++#define indx(a) ( (a)/(32) )
++#define bit(a) ( 1 << ((a)%(32)) )
+
+ #define getloc(a) (regions[indx(a)] & bit(a))
+ #define setloc(a) (regions[indx(a)] |= bit(a))
+
+-static unsigned long regions[ 0x10000/(sizeof(long)*8) ];
++static unsigned long regions[ 0x10000/(32) ];
+
+ void inclc(int i)
+ {