summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-03-07 12:58:36 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-03-07 12:58:36 +0000
commitc597806209f86a10b1a4e122d6fc7fd558cf802a (patch)
tree9c3b440af6e8a8b97b0cde9bbcd2f112ea752bc4
parentfe46d0836cfddb33423a5e3cfa9f243f10de7f19 (diff)
downloadfreebsd-ports-c597806209f86a10b1a4e122d6fc7fd558cf802a.zip
lang/parrot: unbreak with ICU 64
In file included from src/ops/core_ops.c:72: In file included from /usr/local/include/unicode/uchar.h:28: In file included from /usr/local/include/unicode/utypes.h:38: In file included from /usr/local/include/unicode/umachine.h:46: In file included from /usr/local/include/unicode/ptypes.h:52: In file included from /usr/local/include/unicode/platform.h:25: /usr/local/include/unicode/uvernum.h:123:8: error: 'U_DISABLE_VERSION_SUFFIX' is not defined, evaluates to 0 [-Werror,-Wundef] #elif !U_DISABLE_VERSION_SUFFIX ^ PR: 236325 Approved by: portmgr blanket
-rw-r--r--lang/parrot/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index bcba745d30ca..7eaf36df5b2f 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -23,8 +23,8 @@ OPTIONS_DEFINE= DOCS
ALL_TARGET= installable
CONFIGURE_ARGS= --cc=${CC} --cxx=${CXX} --link=${CXX} \
- --ccflags="${CFLAGS} -I${LOCALBASE}/include" \
- --ld=${CC} --ldflags="${LDFLAGS} -L${LIBDIR} -L${LOCALBASE}/lib" \
+ --ccflags="${CFLAGS}" \
+ --ld=${CC} --ldflags="${LDFLAGS}" \
--gc=gms --inline --optimize --parrot_is_shared --verbose \
--prefix=${PREFIX} \
--icu-config=${LOCALBASE}/bin/icu-config \
@@ -35,7 +35,7 @@ INSTALL_TARGET= install-dev
TEST_TARGET= test
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USES= bison gmake perl5 shebangfix tar:bzip2
+USES= bison gmake localbase:ldflags perl5 shebangfix tar:bzip2
SHEBANG_FILES= tools/dev/create_language.pl \
tools/dev/gen_makefile.pl \
tools/dev/pprof2cg.pl \