summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-14 21:30:00 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-14 21:30:00 +0000
commitc2d7202e2b2ded0039da18f54b571f99a4b137bb (patch)
treedfa331b284baa0f44c7c8c3612dafb83318fe41d
parent8e5e429503f9b72e8b12b1ed42e6cc5e2fdc913e (diff)
downloadfreebsd-ports-c2d7202e2b2ded0039da18f54b571f99a4b137bb.zip
net/tcpkali: fix build on GCC architectures
Builds fine with C11 compiler. MFH: 2020Q1 (fix build blanket)
-rw-r--r--net/tcpkali/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/net/tcpkali/Makefile b/net/tcpkali/Makefile
index 174cf27a7f19..d6d7953fda8b 100644
--- a/net/tcpkali/Makefile
+++ b/net/tcpkali/Makefile
@@ -12,7 +12,7 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
GNU_CONFIGURE= yes
-USES= autoreconf compiler libtool gmake ncurses
+USES= autoreconf compiler:c11 libtool gmake ncurses
USE_GITHUB= yes
GH_ACCOUNT= machinezone
@@ -24,10 +24,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-BROKEN= is marked as broken with GCC: src/tcpkali_atomic.h unconditionally includes x86 assembler
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>